Page MenuHomeSolus

GCC miscompiling Mesa causing issues in other software
Open, NormalPublic

Description

I've been having some trouble with Godot and it turns out other people on distros like Arch reported similar stuff and they say there's an issue with Mesa - I don't know exactly what it is but there's a lot of information from other issues and bug reports, I'm wondering if this is a thing we could have fixed in Mesa? it seems other distros have done similar:

https://github.com/godotengine/godot/issues/24340#issuecomment-450727177
https://github.com/godotengine/godot/issues/23423#issuecomment-435877238
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=914366
https://bodhi.fedoraproject.org/updates/FEDORA-2018-bcdb732491

Currently at least for me Godot will often freeze up and I'm sure there's impacts in other programs too, I wish I could be more specific but I don't know exactly what the issue is unfortunately, just that it seems to be with Mesa

smt created this task.Jan 7 2019, 4:48 PM
This comment was removed by Alexander88207.

if i understood it right, it's mesa? and why doesn't anyone report it to mesa?

smt added a comment.Jan 7 2019, 8:48 PM

I have no idea, I tried to read through all the issues and reports in other distros and I'm still not sure what exactly the issue is, but it seems like all of the distros found some way to fix whatever is causing it, I've tried finding other places it's an issue in but the only one that's consistent for me is Godot freezing up

Just try to submit the bug here

smt added a comment.Jan 7 2019, 8:55 PM

ah I wasn't sure if that was the right place, it seems like it is and I found someone else submitting it there too (https://bugs.freedesktop.org/show_bug.cgi?id=109229) if it's not a distro thing I suppose I can close this, was just confused seeing so many distros get fixes out for it

JoshStrobl closed this task as Invalid.Jan 7 2019, 8:57 PM
JoshStrobl added a subscriber: JoshStrobl.

They fixed by reverting Mesa to an older release. Subsequent releases of Mesa were reported to function with Godot, your issue is likely elsewhere seeing as we're on the 18.3.1

sunnyflunk reopened this task as Open.Jan 7 2019, 9:54 PM
sunnyflunk edited projects, added Software; removed Lacks Project.
sunnyflunk added a subscriber: sunnyflunk.

The issue is GCC breaking Mesa, according to the bug reports, this commit fixes it.

https://github.com/gcc-mirror/gcc/commit/5e0169b96bd4dad2c998f79d09e5dff07fb41e9a

Will need to be moved to git

sunnyflunk renamed this task from Mesa causing issues in other software to GCC miscompiling Mesa causing issues in other software.Jan 7 2019, 9:55 PM
DataDrake triaged this task as Normal priority.Jan 20 2019, 1:41 PM
DataDrake moved this task from Backlog to Package Fixes on the Software board.