Page MenuHomeSolus

Package request: dart
Closed, DuplicatePublic

Description

name: dart
homepage: https://www.dartlang.org
why: The Dart programming language is used for mobile, web and to some extend server development.
open source: yes
GitHub: https://github.com/dart-lang/sdk

Google uses a quite complicated build system, which is why many distributions just convert the precompiled archives to packages. But it is possible to build it from source using depot_tools.
Currently, the build process for Dart uses its own toolchain and I already asked them if there is a way to use the distributions toolchain (https://github.com/dart-lang/sdk/issues/35487).
When this is sorted out, I would be able to package and maintain this package.

Event Timeline

flyingP0tat0 updated the task description. (Show Details)
JoshStrobl closed this task as a duplicate of T4974: Dartlang.Dec 23 2018, 7:29 PM