Page MenuHomeSolus

GStreamer cannot find/load Calf audio plugins
Closed, ResolvedPublic

Description

When calf audio plugins is installed Gstreamer should recognize it as valid plugins this can be checked by running gst-inspect-1.0 | grep -i calf currently it returns nothing when it should look like this

This seems to be a installation issue according to the developer of pulse effects as seen on #259

This is a large issue due to PulseEffects having a soft dependency for calf (currently not included in the default package for PulseEffects) providing <85% of the software's effects (thus <85% cannot be enabled and is grayed out)

(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.802: compressor plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.802: filter plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.802: limiter plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.805: bass_enhancer plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.805: crossfeed plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.805: deesser plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.805: exciter plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.805: gate plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.805: loudness plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.805: multiband_compressor plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.805: multiband_gate plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.805: reverb plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.805: stereo_tools plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.806: convolver plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.814: compressor plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.814: filter plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.814: limiter plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.817: deesser plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.817: gate plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.817: pitch plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.817: reverb plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.820: multiband_compressor plugin was not found!
(pulseeffects:25896): pulseeffects-WARNING **: 08:27:42.820: multiband_gate plugin was not found!

Event Timeline

JoshStrobl triaged this task as Low priority.Dec 26 2018, 8:24 PM
JoshStrobl moved this task from Backlog to Improvement on the Software board.
JoshStrobl added a project: Low Hanging Fruit.
JoshStrobl added a subscriber: JoshStrobl.

Confirmed, we do not have pkgconfig(lilv-0) (lilv / lilv-devel, the library responsible for lv2 plugin support) in gstreamer-1.0-plugins-bad package, hence why it is not enabled. Considering this an improvement over a package fix since the gstreamer bad plugins package isn't fundamentally broken.

K4rlos added a subscriber: K4rlos.Apr 2 2019, 5:46 PM

Since the 4.5 update Pulseeffects gets its equalizer from calf, so it's grayed out. Right now, only feature available is autogain, so I consider Pulseeffects broken at this point. Should this thread be continued or new one made?

kyrios123 added a subscriber: kyrios123.EditedApr 3 2019, 5:17 AM

Isn't the pulseeffects issue rather related to the lisp-plug-ins integration?

https://github.com/wwmm/pulseeffects/blob/master/CHANGELOG.md#changed-1

K4rlos added a comment.Apr 3 2019, 1:10 PM

Umm, yes, you're right. Do you know if gst-inspect-1.0 | grep lv2 should give me lv2 plug-ins I have installed? Because it shows nothing.

DataDrake closed this task as Resolved.May 7 2019, 4:01 PM
DataDrake claimed this task.
DataDrake added a subscriber: DataDrake.

This appears to be fixed now. I cannot reproduce.