Page MenuHomeSolus

Qomui missing soft dependency, unexpected configuration path
Closed, ResolvedPublic

Description

Qomui OpenVPN Bypass requires cgexec to function

Steps to reproduce

  1. Install Qomui
  2. Launch from command line to see errors
  3. Options > Allow OpenVPN bypass
  4. Apply
  5. New Panel should show up on left hand side
  6. Bypass > Add Application > About
  7. click the "bypass" button in console it should show an error
nohup: appending output to 'nohup.out'
nohup: failed to run command 'cgexec': No such file or director

Unexpected config path

Qomui Expects iproute2 to be located in /etc/
But on Solus this is located /usr/share/defaults/iproute2

Event Timeline

JoshStrobl triaged this task as High priority.Dec 21 2018, 3:11 PM
JoshStrobl moved this task from Backlog to Package Fixes on the Software board.
JoshStrobl added a subscriber: JoshStrobl.

Unfortunately, qomui is a package that was previously maintained by someone that no longer uses Solus. I'll put up a request for a new maintainer, but I would not advise using this software (not that you can currently, seeing as it appears it wasn't well integrated from the start) in the meantime. Deepest apologies.

Metalking778 renamed this task from Qomui missing soft dependency, unexpected configuration path to th.Jun 16 2020, 8:05 PM
Metalking778 updated the task description. (Show Details)
JoshStrobl renamed this task from th to Qomui missing soft dependency, unexpected configuration path.Jun 16 2020, 8:17 PM
JoshStrobl updated the task description. (Show Details)
JoshStrobl changed the edit policy from "All Users" to "Triage Team (Project)".
JoshStrobl added a subscriber: CGDoctor8.

Sorry about that folks, seems we had a random user being abusive for seemingly no reason.

DataDrake closed this task as Resolved.Sep 27 2020, 10:03 PM
DataDrake claimed this task.
DataDrake added a subscriber: DataDrake.

This has since been fixed.