Page MenuHomeSolus

Wine doesn't detect DXTn nor libgnutls
Closed, ResolvedPublic

Description

I get the following errors in Terminal

err:winediag:schan_imp_init Failed to load libgnutls, secure connections will not be available.
fixme:d3d:wined3d_dxtn_init Wine cannot find the txc_dxtn library, DXTn software support unavailable.

I'm unsure what the lack-of libgnutls affects in my usage, but the lack-of DXTn in World of Warcraft has the cursor missing most of its color/detail and a lot of textures in-game being slightly-to-noticeably washed out.

Performance is also slightly slower, but this could also be due to the graphics driver instead (I use NVIDIA; I've only played WoW on 372 prior to Solus).

I have libgnutls-32bit, libtxc_dxtn-32bit, and the 64-bit versions of those packages installed.

Event Timeline

Espionage724 updated the task description. (Show Details)Sep 18 2016, 5:26 AM
Espionage724 closed this task as Resolved.Sep 19 2016, 12:46 AM
Espionage724 claimed this task.

Hmm, so interestingly enough, both issues have gone away (I no longer see the error messages about libgnutls nor txc_dxtn). I've done a few reinstalls and I'm not entirely certain if I had the tls library installed when I tried WoW, but I can confirm its installed now.

The cursor however is still weird looking, but this also affects another game I play too; I think that deserves a different bug report though.