Page MenuHomeSolus

KeePass auto-type is slow
Closed, ResolvedPublic

Description

For a little while now, the auto-typing has been slower than it used to be. I have to wait a couple seconds for typing to begin, and the typing itself is more of a "human" speed rather than the super fast typing it utilized previously. Not sure if this is an xdotool issue.

yaomtc created this task.Dec 2 2018, 12:04 AM

Hello, i use Solus for a couple of days know on 2 pc at work, i don't see any differences to others OS, the input is super fast...
Are you using KeePassX or the other edition?

yaomtc added a comment.Dec 8 2018, 8:59 PM

@BlueKenny I'm using regular KeePass. Are you using KeePassX?

DataDrake triaged this task as Needs More Info priority.Dec 11 2018, 5:08 AM
DataDrake added a subscriber: DataDrake.

Please try again after the Friday sync as there was a keepass update.

Yes, and i will try both to help you testing

Just updated. Issue is still present. I can go test on Ubuntu to see if the issue is present there too.

Also, their bug tracker is strangely sparse...

yaomtc added a comment.EditedDec 15 2018, 3:49 PM

Using 2.39.1 on Ubuntu, the issue did not occur. I'll try 2.40 there next.

EDIT: That also worked fine. FYI these tests were with 18.10, where xdotool's version is "1:3.20160805.1-4".

yaomtc closed this task as Resolved.Mar 18 2019, 12:03 AM
yaomtc claimed this task.

I've since done a fresh install from the new ISO and it's no longer an issue.