Page MenuHomeSolus

Civilization VI - ibcurl-gnutls.so.4 & libcrypto.so.1.0.0: no version information available
Closed, InvalidPublic

Description

Has there been an ABI and/or API change in the libraries or am I understanding this wrong:

>> GameAction [AppID 289070, ActionID 3] : LaunchApp changed task to ProcessingInstallScript with ""
>> GameAction [AppID 289070, ActionID 3] : LaunchApp changed task to SiteLicenseSeatCheckout with ""
>> GameAction [AppID 289070, ActionID 3] : LaunchApp changed task to CreatingProcess with ""
>> GameAction [AppID 289070, ActionID 3] : LaunchApp waiting for user response to CreatingProcess ""
>> GameAction [AppID 289070, ActionID 3] : LaunchApp continues with user response "CreatingProcess"
>> Game update: AppID 289070 "", ProcID 27866, IP 0.0.0.0:0
>>>>> Adding process 27866 for game ID 289070
>> GameAction [AppID 289070, ActionID 3] : LaunchApp changed task to WaitingGameWindow with ""
>> ERROR: ld.so: object '/home/asiq/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.

>> /harddrive/Backup/SteamLibrary/steamapps/common/Sid Meier's Civilization VI/./Civ6: /usr/lib/libcurl-gnutls.so.4: no version information available (required by /harddrive/Backup/SteamLibrary/steamapps/common/Sid Meier's Civilization VI/./Civ6)
>> /harddrive/Backup/SteamLibrary/steamapps/common/Sid Meier's Civilization VI/./Civ6: /usr/lib64/libcrypto.so.1.0.0: no version information available (required by /harddrive/Backup/SteamLibrary/steamapps/common/Sid Meier's Civilization VI/./Civ6)

>> GameAction [AppID 289070, ActionID 3] : LaunchApp changed task to Completed with ""
>> Game update: AppID 289070 "", ProcID 27872, IP 0.0.0.0:0
>> Setting breakpad minidump AppID = 289070
>> Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198043718864 [API loaded no]
>>>>> Adding process 27872 for game ID 289070
>> ERROR: ld.so: object '/home/asiq/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
>> ERROR: ld.so: object '/home/asiq/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
>>>>> Adding process 28400 for game ID 289070
>> Installing breakpad exception handler for appid(gameoverlayui)/version(20181126201528)
>> Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
>> Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
>> [1129/002407.865987:INFO:crash_reporting.cc(239)] Crash reporting enabled for process: renderer
>> Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
>> JS method call WebChat.GetOverlayChatBrowserInfo with 1 arguments
>> JS method call WebChat.GetOverlayChatBrowserInfo with 1 arguments
>> JS method call Storage.SetString with 2 arguments

Note: Edited the output to see the glaring problem / warning.

The two of those libraries, something to look into or am I just worried for nothing?

Anyhow the game is working properly on multiplayer and singleplayer so I am sitting here wondering if I should make this report/task.

Sethox created this task.Nov 28 2018, 11:47 PM
Sethox updated the task description. (Show Details)Nov 28 2018, 11:49 PM
JoshStrobl closed this task as Invalid.Nov 29 2018, 12:11 AM
JoshStrobl added a subscriber: JoshStrobl.

The two of those libraries, something to look into or am I just worried for nothing?

No, you're worried about nothing.

sunnyflunk added a subscriber: sunnyflunk.

If it works correctly, then there is no issue. An unfortunate consequence of using debs for the runtime.