Page MenuHomeSolus

Wifi Not working
Closed, InvalidPublic

Description

Hey Guys/Gals,

I recently ran updates on my laptop, when I boot into kernel "default Solus-current-4.19.1-98" my wifi adapter does not work. If I boot into an older kernel "4.18.16-97.current" wifi works normally. Thank you @sunnyflunk for walking me through identifying this issue.

This error shows up in dmesg:

[   94.719255] iwlwifi 0000:03:00.0: Could not load the [0] uCode section
[   94.719260] iwlwifi 0000:03:00.0: Failed to start INIT ucode: -5
[   94.719261] iwlwifi 0000:03:00.0: Failed to run INIT ucode: -5
[   94.719262] iwlwifi 0000:03:00.0: Failed to start RT ucode: -5
[   97.319423] iwlwifi 0000:03:00.0: Could not load the [0] uCode section
[   97.319428] iwlwifi 0000:03:00.0: Failed to start INIT ucode: -5
[   97.319429] iwlwifi 0000:03:00.0: Failed to run INIT ucode: -5
[   97.319447] iwlwifi 0000:03:00.0: Failed to start RT ucode: -5

This is the wifi adapter I have:

03:00.0 Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)
	Subsystem: Intel Corporation Dual Band Wireless-AC 8265

Please let me know if there is anything I can provide further.

As always thanks for all your help and building a great OS.

Event Timeline

OddTod created this task.Nov 21 2018, 6:29 AM
DataDrake edited projects, added Hardware; removed Lacks Project.
DataDrake added a subscriber: DataDrake.

Probably need updated firmware.

DataDrake triaged this task as High priority.Nov 21 2018, 10:07 PM

Why would the 8265 require updated firmware to function at all?
The 9260 works with the the included firmware.

bwat47 added a subscriber: bwat47.EditedNov 22 2018, 2:18 AM

I'm running an intel 8265 and the wifi is working without issue on kernel 4.19

3a:00.0 Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)

4.19.1-98.current

hmm. @moriel5 are you sure that your card isn't dying/defective?

moriel5 added a comment.EditedNov 22 2018, 2:52 AM

If my 9260 is dying or defective, than so are all my other 9260s, my AC 3165s, my AC 7260, and my Qualcomm 9377 (have not tested my Realtek card yet), so I do not believe that do be the case.
I can confirm that my slowdown issues are occurring across all PCs in the house, Windows and Linux alike (I have only tested the Qualcomm on my laptop), specifically with updated drivers (I am stuck at how to load a newer firmware on Solus, so I cannot count that).
And to be precise, the slowdowns are on the local network, under load, and only if the load goes on for long enough (say, about 3 hours straight, usually while downloading an obscenely large file, just for stability testing).

One thing I had forgotten to do, which is certainly not good, is to test the performance under the LTS kernel, so I'll do that and post about it.

DataDrake added a comment.EditedNov 22 2018, 3:15 AM

I was specifically referring to the 8265/8275. Edit: thought you were OP.

Your issue is unrelated.

Sorry, I got confused by your post.
The OP did post that their 8265 works on kernel 4.18.16, though.
And I am not sure what they mean, however it may have started working for them on 4.19.1?

Well it's not rocket science. If two people have the same hardware and software but only one of them works, blame the hardware.

moriel5 added a comment.EditedNov 22 2018, 3:48 AM

Do you have a 7265? As I do not (Edit: I too have mistaken one of the posters for the OP).
By the way, @OddTod, after a bit of research, I had found someone posting similar post on the Intel forums.
That person's 7265 came with his laptop, made by Huawei (the model was not posted), and the Intel representative said that their 7265 may have had a customized OEM firmware, perhaps this is a similar situation?
I can say that I had pulled my QCA9377 from a Dell Vostro 3568, so that may have been the reason why it cannot find any networks on kernel 4.9.x-LTS.
Edit: It turns out that the QCA9377 I have is a newer revision than what is officially supported (hw1.1, as opposed to the supported hw1.0).

Edit: Sorry about me mistyping "7265", I was half asleep, due to working the night away on repairing (mainly software) issues on our computers at home (I still need to verify if the audio, graphical, and WiFi (unrelated to my posted issue) issues on my sisters' desktop are due to the monitor outputting too much interference (if so, I'll need a shielded DVI-D cable, I had repaired that monitor) or the CPU compatibility (i3-3220 on a Series-6 Intel-branded motherboard, and the ME firmware is one major version below the required for 3rd gen core CPUs).

bwat47 added a comment.EditedNov 22 2018, 11:50 AM

Do you have a 7265? As I do not (Edit: I too have mistaken one of the posters for the OP).
By the way, @OddTod, after a bit of research, I had found someone posting similar post on the Intel forums.
That person's 7265 came with his laptop, made by Huawei (the model was not posted), and the Intel representative said that their 7265 may have had a customized OEM firmware, perhaps this is a similar situation?
I can say that I had pulled my QCA9377 from a Dell Vostro 3568, so that may have been the reason why it cannot find any networks on kernel 4.9-LTS.

Yeah it might be interesting to know the OP's laptop model

I can say in my case, I'm running a dell xps 13 9360. This laptop came with killer wifi, and I replaced it with an intel 8265 chip due to random crashes with the atheros firmware, so in my case I definitely have a 'vanilla' 8265 firmware

bwat47 added a comment.EditedNov 22 2018, 12:05 PM

In any case, it does seem like there are some others having similar issues with 8265 with recent firmware updates:

https://bugs.archlinux.org/task/60542

https://marc.info/?l=linux-wireless&m=154157387908484&w=2

https://bugzilla.redhat.com/show_bug.cgi?id=1585489

@bwat47 Hey, I am catching up after Thanksgiving. Sorry for the delayed response.

My laptop is a System76 Gazelle, this was last year's model(purchased late December 2017). I don't think the hardware is failing but maybe. Kernel 4.18 works just, I haven't noticed any slowdown the other @moriel5 mentioned. I don't have any stats on this either way though.

I haven't updated the firmware on the wifi card. I'll look in to doing this though.

~ Oddtod

Side note: I don't think it is related, on 4.18 the LUKS password screen went on one line. With the 4.19 kernel it now takes up two lines with a new line some where in the 3/4's mark of the single line version.

@OddTod, I do not think that there is any user-facing way to update the card's firmware, just to get it to load an updated firmware from linux-firmware.
In any case, I would recommend asking System76 about this, especially with their great customer support (I personally am very happy with their support, it's just too bad that warranty support will be complicated in my country, otherwise I would have had a higher chance of buying one of their laptops).

BearzR added a subscriber: BearzR.Nov 24 2018, 10:26 PM

I can't make heads or tails of this, but please do let me know on Friday if the updated linux-firmware or kernel packages help.

DataDrake closed this task as Invalid.Jun 8 2019, 6:20 AM

Closing due to lack of response in over 30 days.