Page MenuHomeSolus

Update python-neovim to 0.3.0
Closed, InvalidPublic

Description

https://github.com/neovim/python-client/releases/tag/0.3.0

diff --git a/package.yml b/package.yml
index 9a90be7..3dcaaaa 100644
--- a/package.yml
+++ b/package.yml
@@ -1,8 +1,8 @@
 name       : python-neovim
-version    : 0.2.6
-release    : 9
+version    : 0.3.0
+release    : 10
 source     :
-    - https://github.com/neovim/python-client/archive/0.2.6.tar.gz : 629c420b6e61b013f339bc6af409c74f9a135210f14e35967c1ceabe2b169c92
+    - https://github.com/neovim/python-client/archive/0.3.0.tar.gz : be59ad9e9490c444d52c271445da57b97474fa6cb137aa1f02fdbb690dca4707
 license    : Apache-2.0
 component  : programming.python
 summary    : Python client for Neovim
diff --git a/pspec_x86_64.xml b/pspec_x86_64.xml
index cde385a..2c7ab78 100644
--- a/pspec_x86_64.xml
+++ b/pspec_x86_64.xml
@@ -2,8 +2,8 @@
     <Source>
         <Name>python-neovim</Name>
         <Packager>
-            <Name>James Lee</Name>
-            <Email>jamesl33info@gmail.com</Email>
+            <Name>Robert Guenzler</Name>
+            <Email>robert@gnzler.io</Email>
         </Packager>
         <License>Apache-2.0</License>
         <PartOf>programming.python</PartOf>
@@ -19,12 +19,12 @@
 </Description>
         <PartOf>programming.python</PartOf>
         <Files>
-            <Path fileType="library">/usr/lib/python2.7/site-packages/neovim-0.2.6-py2.7.egg-info/PKG-INFO</Path>
-            <Path fileType="library">/usr/lib/python2.7/site-packages/neovim-0.2.6-py2.7.egg-info/SOURCES.txt</Path>
-            <Path fileType="library">/usr/lib/python2.7/site-packages/neovim-0.2.6-py2.7.egg-info/dependency_links.txt</Path>
-            <Path fileType="library">/usr/lib/python2.7/site-packages/neovim-0.2.6-py2.7.egg-info/not-zip-safe</Path>
-            <Path fileType="library">/usr/lib/python2.7/site-packages/neovim-0.2.6-py2.7.egg-info/requires.txt</Path>
-            <Path fileType="library">/usr/lib/python2.7/site-packages/neovim-0.2.6-py2.7.egg-info/top_level.txt</Path>
+            <Path fileType="library">/usr/lib/python2.7/site-packages/neovim-0.3.0-py2.7.egg-info/PKG-INFO</Path>
+            <Path fileType="library">/usr/lib/python2.7/site-packages/neovim-0.3.0-py2.7.egg-info/SOURCES.txt</Path>
+            <Path fileType="library">/usr/lib/python2.7/site-packages/neovim-0.3.0-py2.7.egg-info/dependency_links.txt</Path>
+            <Path fileType="library">/usr/lib/python2.7/site-packages/neovim-0.3.0-py2.7.egg-info/not-zip-safe</Path>
+            <Path fileType="library">/usr/lib/python2.7/site-packages/neovim-0.3.0-py2.7.egg-info/requires.txt</Path>
+            <Path fileType="library">/usr/lib/python2.7/site-packages/neovim-0.3.0-py2.7.egg-info/top_level.txt</Path>
             <Path fileType="library">/usr/lib/python2.7/site-packages/neovim/__init__.py</Path>
             <Path fileType="library">/usr/lib/python2.7/site-packages/neovim/__init__.pyc</Path>
             <Path fileType="library">/usr/lib/python2.7/site-packages/neovim/api/__init__.py</Path>
@@ -67,12 +67,12 @@
             <Path fileType="library">/usr/lib/python2.7/site-packages/neovim/plugin/script_host.pyc</Path>
             <Path fileType="library">/usr/lib/python2.7/site-packages/neovim/util.py</Path>
             <Path fileType="library">/usr/lib/python2.7/site-packages/neovim/util.pyc</Path>
-            <Path fileType="library">/usr/lib/python3.6/site-packages/neovim-0.2.6-py3.6.egg-info/PKG-INFO</Path>
-            <Path fileType="library">/usr/lib/python3.6/site-packages/neovim-0.2.6-py3.6.egg-info/SOURCES.txt</Path>
-            <Path fileType="library">/usr/lib/python3.6/site-packages/neovim-0.2.6-py3.6.egg-info/dependency_links.txt</Path>
-            <Path fileType="library">/usr/lib/python3.6/site-packages/neovim-0.2.6-py3.6.egg-info/not-zip-safe</Path>
-            <Path fileType="library">/usr/lib/python3.6/site-packages/neovim-0.2.6-py3.6.egg-info/requires.txt</Path>
-            <Path fileType="library">/usr/lib/python3.6/site-packages/neovim-0.2.6-py3.6.egg-info/top_level.txt</Path>
+            <Path fileType="library">/usr/lib/python3.6/site-packages/neovim-0.3.0-py3.6.egg-info/PKG-INFO</Path>
+            <Path fileType="library">/usr/lib/python3.6/site-packages/neovim-0.3.0-py3.6.egg-info/SOURCES.txt</Path>
+            <Path fileType="library">/usr/lib/python3.6/site-packages/neovim-0.3.0-py3.6.egg-info/dependency_links.txt</Path>
+            <Path fileType="library">/usr/lib/python3.6/site-packages/neovim-0.3.0-py3.6.egg-info/not-zip-safe</Path>
+            <Path fileType="library">/usr/lib/python3.6/site-packages/neovim-0.3.0-py3.6.egg-info/requires.txt</Path>
+            <Path fileType="library">/usr/lib/python3.6/site-packages/neovim-0.3.0-py3.6.egg-info/top_level.txt</Path>
             <Path fileType="library">/usr/lib/python3.6/site-packages/neovim/__init__.py</Path>
             <Path fileType="library">/usr/lib/python3.6/site-packages/neovim/__pycache__/__init__.cpython-36.pyc</Path>
             <Path fileType="library">/usr/lib/python3.6/site-packages/neovim/__pycache__/compat.cpython-36.pyc</Path>
@@ -118,12 +118,12 @@
         </Files>
     </Package>
     <History>
-        <Update release="9">
-            <Date>2018-06-11</Date>
-            <Version>0.2.6</Version>
+        <Update release="10">
+            <Date>2018-11-15</Date>
+            <Version>0.3.0</Version>
             <Comment>Packaging update</Comment>
-            <Name>James Lee</Name>
-            <Email>jamesl33info@gmail.com</Email>
+            <Name>Robert Guenzler</Name>
+            <Email>robert@gnzler.io</Email>
         </Update>
     </History>
 </PISI>
\ No newline at end of file

Details

Differential Revisions
D4364: Update neovim-python to 0.3.0

Sorry if I'm spamming here... I would love to contribute to solus more now. Do I just go ahead and open a pkg update for review if I already have the patch for it? For new pkgs it seems you need to have at least a request for them before submitting them for inclusion

JoshStrobl closed this task as Invalid.Nov 15 2018, 10:58 AM
JoshStrobl added a subscriber: JoshStrobl.

Not sure what you're doing, this isn't the appropriate process for requesting a package update, nor is it necessary to make a task just to update an existing package. Read our documentation:

Sorry for the noise then :p