Page MenuHomeSolus

KDE Restore Session does nothing
Closed, ResolvedPublic

Description

I've install the Patreon ISO on one machine and more recently the public testing ISO on another, on both I have "Restore Previous Session" selected in the "Startup and Shut Down" settings, yet when I bootup there are never any windows open. It seems from Reddit (Shiny Delights) I am not alone on this, although one user said Firefox will remain open for them.

Event Timeline

padraig created this task.Oct 30 2018, 10:51 AM
DataDrake triaged this task as Normal priority.
padraig added a comment.EditedNov 1 2018, 11:07 AM

It's hard to know if this is a general KDE thing or unique to Solus without further testing, same with one or two power management things. It doesn't restore sessions either if I manually save.

I've been using Plasma on my workstation for a while and I rarely shut that down so I didn't notice these kinds of things until I put it on a laptop. I don't want to be creating bug reports here for every little thing! I'll let you know if it gets resolved with a future update anyway.

Any bug no matter how small that isn't an upstream bug, I'd want to fix. The difficult part is determining whether it is an upstream issue or not.

robgriff444 added a subscriber: robgriff444.EditedNov 26 2018, 11:56 AM

Just installed testing ISO v1 after being on Neon Dev Stable for a few weeks - I'm sure it's a Solus thing - I always use it and I've never seen it before anywhere else. It happened straight after an install and eopkg up. I always set up my prefs in Plasma before anything else. I also tried manually saving a session and that didn't work either so I simply autostart everything for now, no biggie for me.

If you need to recreate: install, run eopkg up, open dolphin and konsole and reboot, they will be gone if it is reproduced.

Edit: It worked on the Patreon only Plasma ISO (1st and 2nd), and I've checked KDE's bugtracker and can find nothing relevant for 'restore session'.

It definitely used to work.

Looking at the config files, it appears to save 'a' session, just not what a user would expect. Testing it, it saved a session with firefox, dropbox and pulseaudio.

The problem is the 8 other programs that were opened that weren't saved.

Installed Plasma on a new machine and restore session doesn't restore most apps and in particular no KDE apps, it does restore things like Firefox and Viber but not Dolphin or Okular for example, it also doesn't restore things like TexStudio though which is also QT... This doesn't seem to be a general KDE issue either, just a Solus one.

Girtablulu closed this task as Resolved.Oct 13 2019, 2:45 PM
Girtablulu added a subscriber: Girtablulu.

This should be fixed now

Confirmed, thanks so much!!