Page MenuHomeSolus

WPS Writer: Open File dialog doesn't open under KDE Plasma
Closed, LockedPublic

Description

I don't know what happened, but WPS doesn't want to open files anymore under KDE Plasma. This is a clean install. I tried the workaround of appending -style gtk to the launcher (as I had gotten that advice before on here), but that doesn't help anymore.

The only output I get when clicking Open or pressing Ctrl+O is:

20:03:06 Downloads $ wps
Unexpected value after '--separate-output'.
20:03:06 Downloads $ wps -style gtk
Unexpected value after '--separate-output'.

However, dragging a file from Dolphin to WPS opens it just fine and everything works and it saves all of the changes like it should. So it seems to be confined to the Open File dialog functionality only. I know that I'm probably the only one experiencing this, as always, but I'm hoping to get some help in debugging this anyway. It's not a big deal having to use the Dolphin workaround, but the Open File dialog should work nonetheless.

Event Timeline

Vistaus updated the task description. (Show Details)
Vistaus updated the task description. (Show Details)
Vistaus renamed this task from WPS doesn't open files anymore under KDE Plasma using the Open File dialog to WPS Writer: Open File dialog doesn't open under KDE Plasma.Oct 25 2018, 6:08 PM
Vistaus updated the task description. (Show Details)
sunnyflunk triaged this task as Wishlist priority.Oct 25 2018, 9:27 PM
sunnyflunk added a project: Upstream Issue.
sunnyflunk added a subscriber: sunnyflunk.

So I can actually reproduce this one (it's likely passing options for an older version of kdialog), but I can't fix it and it seems like it would be really easy to test and fix if the source were available. Ah I see this is Qt4, so likely wanting the KDE 4 version of kdialog.

WPS_NO_KDE_NATIVE_DIALOG=1 wps makes it work, without a nice dialog

@sunnyflunk Thanks, that seems to make it work! Although the dialog doesn't play well with dark themes, but it's better than no dialog at all :)

DataDrake closed this task as Wontfix.Feb 9 2019, 8:19 PM
DataDrake added a subscriber: DataDrake.

No longer valid since WPS will soon be removed from 3rd-Party.

Vistaus added a comment.EditedFeb 9 2019, 9:31 PM

@DataDrake Because of that license thing? 'Cause that argument's invalid since that disputable bit is not included in the actual WPS for Linux license: https://github.com/getsolus/3rd-party/issues/9#issuecomment-459958519

Edit: or because 3rd-party is still being migrated to Snap and WPS is available as a snap? https://snapcraft.io/wps-office

But whatever the reason, this issue can remain closed anyway as I can't reproduce it anymore in recent WPS/Plasma versions.

1) You shall guarantee that you will guide the third party to distribute the “Product” (including the repacked “Product”, which means that you consent to the distributing of the repacked “Product” by the third party according to the Agreement without paying any charge to you) in the way licensed in the Agreement in a lawful manner. You shall inform the third party that before first use the “Product” (including the repacked “Product”), they should send an email to Kingsoft at this e-mail address: wps_linux@kingsoft.com and filled out their relevant information (including but not limited to the name of the community, contact person, contact number and address), read through and agree to all the terms of the Agreement. Under the above-mentioned condition, the third party has the right to distribute the “Product” (including the repacked “Product”) according to the Agreement. Otherwise, any use (including without limitation repacking and distributing actions) of the “Product” (including the repacked “Product”) shall be deemed to be unauthorized use, and Kingsoft reserves the right to the legal responsibility.

Unenforceable. Still valid.

Furthermore:

You are only allowed to distribute the “Product” provided by Kingsoft as a whole on an AS IS basis. The distributed “Product” shall only be the unmodified complete (including without limitation the whole content of the attached “Kingsoft Software End-User License Agreement” (hereafter referred to as “Kingsoft EULA”)) version provided by Kingsoft that includes all copyright identification

Vistaus reopened this task as Open.Feb 9 2019, 9:40 PM
1) You shall guarantee that you will guide the third party to distribute the “Product” (including the repacked “Product”, which means that you consent to the distributing of the repacked “Product” by the third party according to the Agreement without paying any charge to you) in the way licensed in the Agreement in a lawful manner. You shall inform the third party that before first use the “Product” (including the repacked “Product”), they should send an email to Kingsoft at this e-mail address: wps_linux@kingsoft.com and filled out their relevant information (including but not limited to the name of the community, contact person, contact number and address), read through and agree to all the terms of the Agreement. Under the above-mentioned condition, the third party has the right to distribute the “Product” (including the repacked “Product”) according to the Agreement. Otherwise, any use (including without limitation repacking and distributing actions) of the “Product” (including the repacked “Product”) shall be deemed to be unauthorized use, and Kingsoft reserves the right to the legal responsibility.

Unenforceable. Still valid.

I don't see how that negates anything, but as I pointed out, it's available as a Snap so it's not a big loss (for me). And you guys want to eventually migrate 3rd-party to Snap anyway, right? Or is that no longer the case (the last time that was talked about was when Ikey was still around)?

Furthermore:

You are only allowed to distribute the “Product” provided by Kingsoft as a whole on an AS IS basis. The distributed “Product” shall only be the unmodified complete (including without limitation the whole content of the attached “Kingsoft Software End-User License Agreement” (hereafter referred to as “Kingsoft EULA”)) version provided by Kingsoft that includes all copyright identification

Hmm, I see what you mean. But anyway: at least you guys now know that there's a specific license for the Linux version, so next time someone brings this up, it's better to point them to that specific license.

JoshStrobl closed this task as Locked.Feb 9 2019, 9:44 PM
JoshStrobl claimed this task.
This task has been locked.