Page MenuHomeSolus

A more reliable WINE
Closed, ResolvedPublic

Description

After comparing several Wine versions I discovered that a problem with (important) missing images in a flash-based app was only present when using Wine Staging versions. Maybe the default system version should not be based on the experimental branch after all and use the more reliable standard version instead.

Related Objects

Event Timeline

Timalex created this task.Sep 16 2016, 7:03 PM
DataDrake closed this task as Invalid.Sep 24 2016, 2:15 PM
DataDrake added a subscriber: DataDrake.

We are already running the wine-staging builds.

There's a game called K-Shoot Mania and it doesn't render at all under Wine Staging. Interestingly enough, it renders and plays (mostly) under regular Wine.

I can't imagine too many other programs having compatibility issues with Staging but not regular Wine, but there are a few that exist.

ikey changed the task status from Invalid to Resolved.Nov 14 2016, 10:43 PM
ikey added a subscriber: ikey.

Changing to resolve because I actually moved our Wine off of staging.

Hmm, Wine still reports it's staging to me and I have a CSMT option under a Staging tab in winecfg.

That would be because its still in the unstable repo :P

Ah :p

Although on a different note, will Staging be provided as a separate package? CSMT is kind of nice for some games/setups.

No. People either want staging or they don't. Can't have your cake and eat it :)

Hmm, why cant we have both in this case? Regressions will happen regardless it's upstream or staging anyway.

I'd like to see both too, but even just Staging was alright for my main usage.

The game I mentioned a little bit ago K-Shoot MANIA renders only in plain Wine, but still doesn't run well enough to actually be usable (there's other problems with it related to GDI+). Even if it did though, I value CSMT with Staging way more (and the additional fixes it adds sound nice on-paper :p)

Hmm, why cant we have both in this case? Regressions will happen regardless it's upstream or staging anyway.

Because that's not how we build Solus. One provider for a Thing. No conflicts.

In T700#27120, @ikey wrote:

People either want staging or they don't.

One provider for a Thing. No conflicts.

Well...If we can only have one, I must admit I'd prefer staging. I believe the advantages of staging (greater compatibility with titles, CSMT, etc) outweigh the minor negatives, especially if Gallium-Nine is to one day be merged with Staging.

But that's just my 0.02¢ :)

Is the decision to move to regular Wine final for now? I mainly play two games with Wine (Guild Wars 2 and Path of Exile), and both require CSMT to play ideally. GW2 loses FPS without it (about 10-20 FPS depending on the scenario), and PoE becomes a flickering mess without it unless I disable the in-game multithreading (which also lowers FPS a bit).

@Espionage724 Gallium Nine with CSMT is now a thing and it's faster than Wine+CSMT. In some scenarios it's even faster than Windows. So once gallium-nine patches are merged into wine-staging we'll be able to use it so I'm voting for staging. If not now then at least in the future.

In T700#27501, @ikey wrote:

Hmm, why cant we have both in this case? Regressions will happen regardless it's upstream or staging anyway.

Because that's not how we build Solus. One provider for a Thing. No conflicts.

Then you may want to remove vivaldi-snapshot as well and just stick with the stable Vivaldi releases.

@Vistaus Vivaldi Snapshot and Vivaldi Stable don't conflict.

Vistaus added a comment.EditedMar 4 2017, 10:20 AM

@Vistaus Vivaldi Snapshot and Vivaldi Stable don't conflict.

I've had them conflict on Arch before I switched to snapshot-only after moving to Solus. So if they do conflict on Arch, then how come they don't conflict on Solus?

So if they do conflict on Arch, then how come they don't conflict on Solus?

Because we're not Arch.

Vistaus added a comment.EditedMar 4 2017, 10:23 AM

So if they do conflict on Arch, then how come they don't conflict on Solus?

Because we're not Arch.

I know, but there's gotta be a technical reason for it and I'd love to know said reason because plain Vivaldi/Vivaldi Snapshot is closed source and therefore should in theory be the same everywhere, so if there are conflicts, they should in theory also be everywhere.

I'd love to know said reason because plain Vivaldi/Vivaldi Snapshot

You're welcome to look at the vivald-stable and vivaldi-snapshot git repos then. This is off-topic.

I'd love to know said reason because plain Vivaldi/Vivaldi Snapshot

You're welcome to look at the vivald-stable and vivaldi-snapshot git repos then. This is off-topic.

I'm not that much of a tech guy so maybe you could explain it to me? I know it's off-topic, but maybe you could message me some other way (email or something)?

@Vistaus Vivaldi Snapshot and Vivaldi Stable don't conflict.

Regular Wine and Staging don't have to conflict either, it's all a matter of packaging. I believe Wine Staging on Ubuntu can also be installed side-by-side with regular Wine, but they provide a package to allow Staging to be system-wide if desired (info).

@ikey Please re-add wine-staging. Stable is ancient by now. It has lower compatbility and performance(can't even run DOOM). The entire debate between stable and staging is pointless as software of this nature can never be considered stable or finished. Besides, we spoke about gallium-nine implementation a few months ago and, in fact, there's already a pull request waiting to be merged into staging.

Just throwing this out here, Wine Staging 3.4 is out already and I think we should really switch it over or at least add it.

My vote also goes to Staging, basically everything I can think of runs tons better on Staging than just plain Wine.

@tenten8401 We aren't switching to staging. Did it once and ended up back on stable again because it caused too many problems. Please don't necro old tasks.