Page MenuHomeSolus

rp-pppoe
Closed, WontfixPublic

Description

rp-pppoe

https://www.roaringpenguin.com/products/pppoe

This package is needed for DSL/PPPoE connections, I can't connect to broadband without it, it is available in other major distros.
When I try to connect after adding DSL connection in NetworkManager, I get this:

NetworkManager[625]: <info> [1537979777.7922] ppp-manager: starting PPP connection
NetworkManager[625]: /usr/sbin/pppd: /usr/lib/pppd/2.4.7/rp-pppoe.so: cannot open shared object file: No such file or directory
NetworkManager[625]: /usr/sbin/pppd: Couldn't load plugin rp-pppoe.so
pppd[1651]: /usr/lib/pppd/2.4.7/rp-pppoe.so: cannot open shared object file: No such file or directory
pppd[1651]: Couldn't load plugin rp-pppoe.so

It is open source:
https://www.roaringpenguin.com/files/download/rp-pppoe-3.12.tar.gz

I also think because they are required for Internet connection, ppp and pppoe should be included in the default ISOs.

mustafa created this task.Sep 26 2018, 5:03 PM
DataDrake triaged this task as Low priority.Oct 16 2018, 10:13 PM
DataDrake moved this task from Backlog to Accepted For Inclusion on the Package Requests board.
DataDrake closed this task as Wontfix.Nov 17 2018, 2:19 PM
DataDrake added a subscriber: DataDrake.

As this task has been marked Needs Maintainer for a month with nobody having stepped up to become maintainer, in addition to providing an acceptable patch for inclusion, marking as WONTFIX. Feel free to re-open when a patch has been submitted via the proper processes.

mustafa added a comment.EditedNov 18 2018, 6:15 AM

The problem is that in my country (Iraq), all ISPs use PPPoE, I assume there are other countries like this.
Sure, there can be a router in between, but this breaks some people's setups, I saw discussions about this in Solus forums too.

Hasshu added a subscriber: Hasshu.Nov 27 2018, 10:53 AM

The problem is that in my country (Iraq), all ISPs use PPPoE, I assume there are other countries like this.

It's similar in Russia, where PPPoE is often the only way to access the Internet. In fact, I had to uninstall Solus earlier this month, as I simply couldn't come online.

Nobody is arguing against having it, but someone actually needs to step up and become the maintainer, submit patches, etc.

@JoshStrobl Well, I, for one, am merely trying to raise awareness of the issue, since PPPoE isn't as uncommon as many seem to believe. It should work out of the box, especially considering that nm-connection-editor has an option for it.

I think you will find that https://dev.getsol.us/R2474:4af5a6885aafa2f5b70cd181ee3f2de996d77b6a resolves the problem you are facing, rather than including this package which doesn't have the plugin you need.

I think you will find that https://dev.getsol.us/R2474:4af5a6885aafa2f5b70cd181ee3f2de996d77b6a resolves the problem you are facing, rather than including this package which doesn't have the plugin you need.

I hope this fixes the problem, is there a way to test this or should I wait until it reaches updates?

I think you will find that https://dev.getsol.us/R2474:4af5a6885aafa2f5b70cd181ee3f2de996d77b6a resolves the problem you are facing, rather than including this package which doesn't have the plugin you need.

This indeed fixed my problem, now I can use my PPPoE connection, thank you :)