Page MenuHomeSolus

qgis should stay on lts
Closed, WontfixPublic

Description

Hi,

i think it would be a good idea to stay with the QGIS package on the lts channel. Because:

  1. The developers of the plugins (where many people rely on) mostly target the LTS.
  1. Not so much changes in the packaging :)

In know that solus is rolling but i think in this case it doesnt make sense.

Just a suggestion :)

Event Timeline

mramish created this task.Sep 22 2018, 5:15 PM

We switched to QGis 3.x in March and haven't got any complaint, so I'm quiet surprised to see this now.

Yes because 3.x was a huge step from 2.x and that was good. It is only a suggestion because in large science projects we like to use software that does not change every x month. Maybe solus could offer the lts and the current version ?

When 3.x has an lts version of course

No, only in rare instances do we offer multiple "providers" for software, typically for backwards compatibility reasons.

Ok, then maybe stay on version 3.x when it becomes lts would be an option ?

kyrios123 added a comment.EditedSep 23 2018, 8:17 AM

Which plugins do you miss ?
I know there are still some plugins that aren't available in QGis 3.x but if that really was an issue for someone, I guess people would have yelled at us and there are also a few plugins that are only available for 3.x that you'll never have in the LTS version.

QGis 2.x is Qt4 & Python2 based. Qt4 is being out phased and Python 2 is getting on its end.

mramish added a comment.EditedSep 23 2018, 8:31 AM

Dont get me wrong. At the moment iam missing nothing and my first post was just a suggestion when the 3.x branch gets an lts release.

DataDrake closed this task as Wontfix.Sep 23 2018, 1:47 PM
DataDrake added a subscriber: DataDrake.

If you had no issues going from 2 to 3, I doubt you will have issues going from 3 to 4. Either way, that's a long way out and we will decide what to do when that time comes.