Page MenuHomeSolus

tomahawk
Closed, DuplicatePublic

Description

Name: Tomahawk
Homepage and tarball source: https://www.tomahawk-player.org/
Open Source: Yes

Tomahawk is a free multi-source and cross-platform music player. An application that can play not only your local files, but also stream from services like Spotify, Beats, SoundCloud, Google Music, YouTube and many others. You can even connect with your friends' Tomahawks, share your musical gems or listen along with them. Let the music play!

(P.S. No, it's not like Nuvola, this player supports local files and everything is done in the GUI)

Event Timeline

sunnyflunk closed this task as a duplicate of T540: Tomahawk.Sep 16 2016, 9:37 AM