Page MenuHomeSolus

Lightdm fails to start
Closed, ResolvedPublic

Description

So after updating my machine today, lightdm is failing to start on bootup. For kicks, I just did a fresh install on a separate drive, and did nothing but apply updates. Upon rebooting, the same thing happened. I tried installing and booting from the LTS kernel, but again had the same issue. Also tried booting with "nomodeset" but that didn't make a difference either.

Elvanex created this task.Sep 1 2018, 1:57 AM

The same issue here. New install of Mate edition, blinking cursor instead of lightdm.
Tried the lts kernel too but nothing better.

watpi added a subscriber: watpi.Sep 1 2018, 10:52 AM

Same thing on a Dell Optiplex 760 with Radeon HD 3450 (Solus MATE). Another machine with MATE version does boot OK.

Riokei added a subscriber: Riokei.Sep 1 2018, 11:15 AM

Same issue with a Dell XPS 420.

watpi added a comment.Sep 1 2018, 12:20 PM
This comment was removed by watpi.
clauded added a subscriber: clauded.Sep 1 2018, 2:35 PM

Same problem here with a Dell studio XPS. Was able to rollback with 'eopkg history -t <transaction number>'.

@clauded Can you list what was in that upgrade transaction please?

m1chas added a subscriber: m1chas.Sep 1 2018, 3:03 PM
JoshStrobl edited projects, added Software; removed Lacks Project.Sep 1 2018, 3:54 PM

For those that have experienced issues with graphics, please perform a sudo eopkg up (there will be libdrm 2.4.94 rel 24 and mesalib 18.1.6 rel 100 updates) and reboot. If the issue persists, ensure inxi is installed on your system and get the details for inxi -b. If it's resolved, please let us know here. Thanks!

JoshStrobl triaged this task as High priority.Sep 1 2018, 4:29 PM

Just did a full update, re-started with no issues.

m1chas closed this task as Resolved.EditedSep 1 2018, 4:40 PM
m1chas claimed this task.

It seems that the issue is resolved. Thanks!
BTW, I'm new here, I didn't mean to close the task, sorry.

JoshStrobl reopened this task as Open.Sep 1 2018, 4:42 PM

Hey, good to hear it is resolved. I'm going to wait to hear from everyone else before this gets marked as resolved.

spokorsk added a comment.EditedSep 1 2018, 4:54 PM

Is it resolved with mesalib 18.1.6-100,

Thank a lot and to be continued...

RE : I spoke too fast, it's ok after having passed the last version of mesalib but nok for the following packages:

57: update

Date: 2018-09-01 18:50

  • mpv-libs is updated from 0.27.2-54-1-x86_64 to 0.27.2-55-1-x86_64 with delta.
  • libgtk-3 is updated from 3.22.30-80-1-x86_64 to 3.22.30-81-1-x86_64 with delta.
  • libgtk-3-32bit is updated from 3.22.30-80-1-x86_64 to 3.22.30-81-1-x86_64 with delta.
  • qt5-base is updated from 5.11.1-27-1-x86_64 to 5.11.1-28-1-x86_64 with delta.
  • mutter is updated from 3.28.3-44-1-x86_64 to 3.28.3-45-1-x86_64 with delta.
  • ibus is updated from 1.5.18-12-1-x86_64 to 1.5.19-13-1-x86_64 with delta.
  • clutter is updated from 1.26.2-20-1-x86_64 to 1.26.2-21-1-x86_64 with delta.
  • atom is updated from 1.29.0-110-1-x86_64 to 1.30.0-111-1-x86_64 with delta.
  • onboard is updated from 1.4.1-7-1-x86_64 to 1.4.1-8-1-x86_64 with delta.

Operation # 56: update
Date: 2018-09-01 18:48

Sxu99 added a subscriber: Sxu99.Sep 1 2018, 4:59 PM

For me the problem was also solved!!

Thanks ^_^

@spokorsk Doesn't make a whole lot of sense, aside from ibus and atom those are just rebuilds.

Solved here also. Thanks for the quick fix!

@JoshStrobl My apologies, it's ok after a clean reboot.

Best regards,

JoshStrobl closed this task as Resolved.EditedSep 1 2018, 5:31 PM

Great to hear this has resolved the issue. Thank you everyone for your testing and we apologize for it breaking in the first place.

I know I'm a bit late, but as the original poster, I felt I had to confirm that it is solved for me as well. :) Thanks for the quick fix!

watpi added a comment.Sep 2 2018, 11:29 AM

Seems to work after upgrade. Thanks for your efforts and quick response!