Page MenuHomeSolus

Issues launching some of Steam's Proton-supported games
Closed, InvalidPublic

Description

Yesterday, Valve announced the new beta version of Steam Play that's bundled with Proton, a special version of Wine. Currently, they've whitelisted 27 games previously unavailable on Steam for Linux.

https://steamcommunity.com/games/221410/announcements/detail/1696055855739350561

I personally own a few of them. S.T.A.L.K.E.R.: Shadow of Chernobyl works for me without issue. However, the two Mount & Blade games do not launch. I've attached the terminal output. If others have issues launching games on this list, maybe they can post them here.


yaomtc created this task.Aug 22 2018, 5:27 PM
Sethox added a subscriber: Sethox.EditedAug 22 2018, 5:35 PM

I cannot get Proton to run at all. Researched a bit and I thought that it had to do with not having python 3.7, I was going to add a task for upgrading for it while I accidentally pressed ctrl+q. Well I stumbled on this so I was better off.

Edit: Steam just decided to work now. No change anywhere what so ever, tested the same things while reading online what the cause could be.

Python has something to with Proton? Well, either way it would be nice to have the newest version in the repos. Done.

https://dev.solus-project.com/T6817

Python has something to with Proton?

It requires python 2.7

fazo96 added a subscriber: fazo96.Aug 23 2018, 5:08 PM
DataDrake triaged this task as Needs More Info priority.Oct 16 2018, 8:38 PM
DataDrake added a subscriber: DataDrake.

We've made several improvements in the last month or so that should have helped this. Are we still seeing this problem?

JoshStrobl closed this task as Invalid.Nov 4 2018, 12:18 PM
JoshStrobl added a subscriber: JoshStrobl.

Closing due to lack of response.

yaomtc added a comment.Nov 4 2018, 4:12 PM

Yeah it's working fine now, sorry. For some reason I never got emailed for @DataDrake's response.