Page MenuHomeSolus

geoclue demo agent missing ?
Closed, WontfixPublic

Description

In geoclue package there is /usr/share/applications/geoclue-demo-agent.desktop

[Desktop Entry]
Name=Geoclue Demo agent
GenericName=Demo geoclue agent
Keywords=geolocation;
Exec=/usr/lib/geoclue/geoclue-2.0/demos/agent
Icon=mark-location-symbolic
NoDisplay=true
Terminal=false
Type=Application

But /usr/lib/geoclue/geoclue-2.0/demos/agent doesn't exists in the system

Related Objects

Event Timeline

Devil505 created this task.Aug 21 2018, 5:05 AM
JoshStrobl closed this task as Wontfix.Aug 21 2018, 5:07 AM
JoshStrobl claimed this task.
JoshStrobl added a subscriber: JoshStrobl.

Demo agent is included in newer release of geoclue, however I need to implement an agent in Budgie, so it's being held back. At this moment in time, geoclue functions as intended with the right set of apps (like Maps), so marking this as WONTFIX. See D2935

Thanks for the clarification. Maybe this is why redshift auto geolocation via geoclue doesn't work for me.

Yea, most of the fixes to demo agent was done in 2.4.9 so not something I can upgrade us to yet. Sorry, I'll have it sorted for Budgie 10.5 hopefully. But with newer geoclue it's mostly broken for me during my testing.