Page MenuHomeSolus

Min Browser
Closed, DuplicatePublic

Description

Name Min Browser

Homepage https://minbrowser.github.io/min/

Why should this be included in the repository? Min is an open source web browser with a clean UI and minimalist look. Despite being minimal, Min packs enough features for a standard web browsing experience. Min is an open source web browser written using CSS and JavaScript using Electron.

If we already offer similar software in our repository or third party, please provide information on what your proposed software does that our existing offerings don’t (differentiators).

  • Minimalistic user interface
  • Fuzzy search in the address bar to quickly get search engine suggestions and from the web browsing history.
  • DuckDuckGo is the default search engine, but it can be changed to use other search engines
  • Built-in ad and script blocking. This can be enabled from menu->Edit->Preference.
  • Tabs can be grouped into ‘tasks’, which is basically collections of tabs. You can switch between the tasks to have one group of tabs visible and in use.
  • Reading mode allows you to view a webpage as a book page for easier reading. Every time you open a webpage in reading mode, it is saved to a reading list for 30 days.
  • Focus mode allows you to concentrate on current tab by hiding all other tabs.
  • Browser actions quickly do several things, even if you don’t remember the keyboard shortcut. For example, using !se in the address bar will suggest !settings browser action for opening the settings menu.
  • Dark mode
  • Easy on system resources
  • Plenty of keyboard shortcuts
  • PDF viewer

Is it Open Source? Yes

Who and how many users do you anticipate will use this software? Anyone looking for a minimalist but speedy browser.

Link to source tarball/zip file https://github.com/minbrowser/min/archive/v1.7.1.tar.gz

Event Timeline

DataDrake closed this task as a duplicate of T6141: Min (browser).Aug 19 2018, 11:13 PM