Page MenuHomeSolus

Removing cups from packaged manager also removes other programs
Closed, InvalidPublic

Description

I attempted to print a document using a printer on my home network, the printer would show up and then disappear, I thought that I would remove cups and reinstall it.

I found the cups package hit the uninstall button which brought up the dependencies window to remove as well, without looking closely at what “dependencies” would actually be removed.. this resulted in the deletion of 240 programs/applications from my system. Even core parts of the Solus OS leaving me with just a terminal window.
I followed the instructions on rolling back the eopkg package manager found here:

https://solus-project.com/articles/package-management/history-and-rollback/en/

Which saved my ass, but had me sweating bullets...
It took about half an hour to reinstall deleted packages, save a few like Firefox which for some reason after logging back in had to go to back to the software center and reinstall manually, but appears to be back as it was..

worldwar345 edited projects, added Software, Restricted Project, Triage Team; removed Lacks Project.Aug 10 2018, 8:16 AM
JoshStrobl closed this task as Invalid.Aug 10 2018, 8:17 AM
JoshStrobl added a subscriber: JoshStrobl.

So everything worked as intended then. The Software Center removed the packages you requested. For a reinstall of a package, I'd suggest following https://solus-project.com/articles/package-management/basics/en/#reinstalling-software

JoshStrobl removed projects: Triage Team, Restricted Project.Aug 10 2018, 8:17 AM

Yes, I suppose that it did, I assumed that not all the applications being removed were actually dependencies of cups.