Page MenuHomeSolus

Firefox menu transparency makes text unreadable
Closed, ResolvedPublic

Description

I've always used my laptop with just the iGPU but recently I added a second display and the HDMI port is linked to the discrete gpu so nvidia crappy drivers here i come.

Since I installed the nvidia drivers i had the firefox menu (the three horizontal lines) and the single plugins menu (noscript, ublock origin, etc.) totally unreadable when the background page is light. Unfortunately I was unable to caputure the situation with Spectacle because it can't see the open menu. Maybe this is part of the problem.
If i load a dark webpage i can see the menu, and this is suggesting that the characters are transparent.

Is this somehow fixable?

Thank you!

DE: KDE
WM: KWin
WM Theme: breeze
Theme: Numix [KDE], Numix [GTK2/3]
Icons: Papirus [KDE], Papirus [GTK2/3]

Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915 v: kernel 
           Card-2: NVIDIA GK104GLM [Quadro K3100M] driver: nvidia v: 390.77 
           Display: x11 server: X.Org 1.19.6 driver: modesetting,nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: Quadro K3100M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.77

Event Timeline

DataDrake edited projects, added Hardware; removed Lacks Project.Jul 29 2018, 3:56 PM

I'm not quite understanding. Are you setting transparency anywhere?

What's the configuration where it does work correctly?

  • Simply removing the nvidia drivers?
  • Does it work with the nvidia drivers plugged in with only one monitor (plugged into nvidia card)?
Brandywine added a comment.EditedAug 5 2018, 10:02 PM

Are you setting transparency anywhere?

I have transparency enabled in plasma (sadly my nvidia card isn't up to the game for the new blur) but I think this issue is unrelated.
I can tell you something more about this graphic glitch: the background of the menu is clear, but the content is transparent. So, if you open the firefox menu, for example, the "Library" voice or "Settings" is transparent, like the characters are an alpha channel. This is valid for icons also, whatever the color.
This happens ONLY IN FIREFOX.

What's the configuration where it does work correctly?

edit: with the iGPU it works as expected.

Simply removing the nvidia drivers?

Yes, that worked.

Does it work with the nvidia drivers plugged in with only one monitor (plugged into nvidia card)?

No, with nvidia drivers and no external display it still glitches. I think we can rule out the external monitor.

Brandywine added a comment.EditedAug 6 2018, 8:35 PM

I found this: https://support.mozilla.org/en-US/questions/1225327

Chosen solution

I changed the KDE rendering backend to xrender and it works again!

Unfortunately for me, changing from opengl 3.1 to xrender didn't solve my issue.

If I DISABLE the compositor I finally can see again the menus but you know how is the desktop without compositing. Sad.

Last update: if I go to about:config and set the
layers.acceleration.force-enabled to false the problem is fixed.

I don't know why it was set to true because it seem that false is the default.

I think we can close this task, thank you!

sunnyflunk closed this task as Resolved.Aug 7 2018, 12:48 AM
sunnyflunk claimed this task.

Alright, I guess sane defaults wins the day and there are reasons why a couple of 'performance' knobs aren't turned on.

Thanks for looking into it.