Page MenuHomeSolus

klauncher error after updating KDE
Closed, ResolvedPublic

Description

Some updates (like last Friday's for example) cause issues for me with ktf5.

Opening Dolphin gives an empty folder with this in red (I also get this if I try to open a file in other programs):
Unable to create io-slave. klauncher said: Error loading '/usr/lib64/qt5/plugins/kf5/kio/file.so'.

Opening it in the command line gives the following:

qt.accessibility.core: Cannot create accessible child interface for object:  PlacesView(0x166d5a0)  index:  8
kf5.kio.core: couldn't create slave: "klauncher said: Error loading '/usr/lib64/qt5/plugins/kf5/kio/trash.so'."
kf5.kio.core: "Unable to create io-slave. klauncher said: Error loading '/usr/lib64/qt5/plugins/kf5/kio/trash.so'."
kf5.kio.core: couldn't create slave: "klauncher said: Error loading '/usr/lib64/qt5/plugins/kf5/kio/file.so'."
kf5.kio.core: couldn't create slave: "klauncher said: Error loading '/usr/lib64/qt5/plugins/kf5/kio/file.so'."
kf5.kio.core: couldn't create slave: "klauncher said: Error loading '/usr/lib64/qt5/plugins/kf5/kio/file.so'."
kf5.kio.core: couldn't create slave: "klauncher said: Error loading '/usr/lib64/qt5/plugins/kf5/kio/file.so'."
kf5.kio.core: We got some errors while running testparm "Load smb config files from /usr/share/defaults/samba/smb.conf\nGlobal parameter load printers found in service section!\nGlobal parameter printcap name found in service section!\nGlobal parameter disable spoolss found in service section!\nLoaded services file OK.\n"
kf5.kio.core: couldn't create slave: "klauncher said: Error loading '/usr/lib64/qt5/plugins/kf5/kio/file.so'."

This came up in the terminal after:

file:///usr/share/plasma/plasmoids/org.kde.plasma.mediacontroller/contents/ui/ExpandedRepresentation.qml:191:5: QML Image: klauncher said: Error loading '/usr/lib64/qt5/plugins/kf5/kio/http.so'.
qt.qpa.xcb: QXcbConnection: XCB error: 2 (BadValue), sequence: 18338, resource id: 44040211, major code: 142 (Unknown), minor code: 3
qt.qpa.xcb: QXcbConnection: XCB error: 2 (BadValue), sequence: 18388, resource id: 73400326, major code: 142 (Unknown), minor code: 3
qt.qpa.xcb: QXcbConnection: XCB error: 2 (BadValue), sequence: 18411, resource id: 44040211, major code: 142 (Unknown), minor code: 3
file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:342: Unable to assign [undefined] to int
org.kde.plasmaquick: Applet "Application Launcher" loaded after 0 msec
org.kde.plasmaquick: Increasing score for "Application Launcher" to 100
QObject::connect: invalid null parameter
file:///usr/share/plasma/plasmoids/org.kde.plasma.kickoff/contents/ui/KickoffItem.qml:211:19: Unable to assign [undefined] to QString
file:///usr/share/plasma/plasmoids/org.kde.plasma.kickoff/contents/ui/KickoffItem.qml:211:19: Unable to assign [undefined] to QString

You can also see the error on the desktop background:

This is resolved after a reboot, however it does not resolve just by restarting plasma alone, it has to be a full reboot.

This has happened me three times now since I've started using Plasma a few months ago. I tend not to reboot my workstation often and it has happened each time after an update.
Apologies if this is a known issue, I didn't see it when searching. I did mention it in another task but not in as much detail.

Also I have rebooted since as I needed a file manager so can't replicate it immediately!

Event Timeline

padraig created this task.Jul 26 2018, 11:10 AM

You appear to be the only one experiencing this. I suggest you perform a full update and then validate your packages.

sudo eopkg up
sudo eopkg install --reinstall kio kinit

Then validate your installed packages as per https://solus-project.com/articles/troubleshooting/general-troubleshooting/en/

Also did you install via ISO?

padraig added a comment.EditedJul 26 2018, 12:37 PM

The system is up to date.

Edit: Turns out Breeze-icons was broken
Checking integrity of breeze-icons Broken

I wonder if that was the cause.

Yeah I installed with the second Patreon ISO.

You'll get a chance on Friday to test this:

Please install strace sudo eopkg install strace

Run this if you suffer the same issue:

strace -o ~/dolphin.strace -f dolphin

and then I want to see ~/dolphin.strace

Thanks Peter, I'll let you know (though it may be Monday before I've a chance to test it).

I haven't suffered any issues this time so maybe validating the packages sorted it? I still get an error opening it from the command line:

$ qt.accessibility.core: Cannot create accessible child interface for object:  PlacesView(0x16be290)  index:  11
kf5.kio.core: We got some errors while running testparm "Load smb config files from /usr/share/defaults/samba/smb.conf\nGlobal parameter load printers found in service section!\nGlobal parameter printcap name found in service section!\nGlobal parameter disable spoolss found in service section!\nLoaded services file OK.\n"

But it does work. When I run strace -o ~/dolphin.strace -f dolphin I get:

qt.accessibility.core: Cannot create accessible child interface for object:  PlacesView(0x1a8f550)  index:  11
kf5.kio.core: We got some errors while running testparm "Load smb config files from /usr/share/defaults/samba/smb.conf\nGlobal parameter load printers found in service section!\nGlobal parameter printcap name found in service section!\nGlobal parameter disable spoolss found in service section!\nLoaded services file OK.\n"

~/dolphin.strace tends to keep expanding but I've attached it after it first creates it here

Don't worry if you don't get a chance to ever look at this, glad it's working now anyway!

sunnyflunk closed this task as Resolved.Aug 20 2018, 11:07 AM
sunnyflunk claimed this task.

Just some samba outputs, not really anything to worry about.