Page MenuHomeSolus

OpenJDK & OpenJFX Upgrade to 11
Closed, ResolvedPublic

Description

Our Java Stack is relatively not-very-well-maintained, let's try to see if we can upgrade the entire stack to JDK 11.

As of 2020-06-12, all packages that can be updated to JDK 11 have been updated to JDK 11. Thankfully, most of these were painless upgrades. Six packages could not be upgraded—four of these will be deprecated, and the other two have been made to use JDK 8 until they become compatible with JDK 11.

As of 2020-06-14, all changes have been approved, and the patches are being pushed to unstable. If you use any of this software, please give it a look and make sure it still works after the update.

As of 2020-06-17, all patches have been pushed to unstable. Again, please test before this lands in stable. In addition, the four packages marked for deprecation have been deprecated.

As of 2020-06-22, the additional patches that were found to be required have been pushed. I'd consider this upgrade successful. As such, this task will now be closed, and a new one created for the potential deprecation of openjdk-8.

Java Itself

  • OpenJDK 11
    • Note: Since we don't provide JDK 10 the initial build needs to be bootstrapped as it works on a n=n OR n-1 principle to build.
    • JRE's have been deprecated but can still be built with make legacy-jre-image

Note: both of these are licenced under GPL-2.0-with-classpath-exception but this licence has been deprecated by SPDX from 2.0rc2 onwards.

Build Tools

  • Ant (apache-ant)
    • Requires documentation to not be built.
  • Maven (apache-maven)
  • gradle
    • Some programs may require an older version (use gradlew instead)
  • sbt

Dependencies

  • chatty
  • pdfsam
  • ipscan
  • dbeaver
  • projectlibre
  • kotlin-native
  • icedtea-web
    • Doesn't build against JDK 11 as of version 1.8.4
  • freeplane
  • scala
  • jitsi
    • Doesn't build against JDK 11 as of version 5633
  • modelio
  • jxrlib
  • octave
  • libreoffice
  • darktable
    • Doesn't actually require a JDK to build
  • kodi
  • fop
  • closure-compiler
  • cryptomator
  • jabref
    • No stable version builds against JDK 11. Latest 4.x builds against JDK 10, latest 5.x builds against JDK 14
  • bisq
  • arduino
  • minecraft

Awaiting Deprecation

  • kontalk
  • bfg-repo-cleaner
  • i2p
  • java-service-wrapper

Related Objects

Mentioned In
R4769:87c952ff36b5: Update ArduinoIDE to 1.8.13
R4069:1780ee589542: Update cryptomator to 1.5.0
R4063:16e4da2467bd: Update bisq to 1.3.5
R2852:f8ad341ba76a: Use JDK11 for Scala and fix REPL
R1571:de1cd8646ada: Build kodi with JDK11
R1835:50e543d5138c: Build libreoffice with JDK11
R4853:801cbe55362f: Use packaged Gradle for kotlin-native build
R846:8ccfa60da4b4: Update freeplane to 1.8.5
R1482:52ffa5277903: Update ipscan to 3.7.2
R510:6eab0be841b5: Update chatty to 0.12
R4887:bd1642ebd14a: Update fop to 2.5
R4954:0d5ebb9d0e86: Update closure-compiler to 20200517
R4068:64eab34fffb8: Use jdk11 for modelio
R2217:6d6c88eef15c: Use openjdk-11 to build octave
R595:28bef0586909: Update dbeaver to 7.1.0
R3859:1cfa1687bebc: Use openjdk-11 for pdfsam
R4313:a6ca05bac5b6: Update jxrlib to 0.2.4
R4185:0bbac5509871: Use JDK11 for projectlibre
R1500:8bbc671735c0: Use openjdk-8 to build jitsi with ant
R2851:f376d63e6ecd: Update sbt to 1.3.12
R1050:2b357761f21a: Update Gradle to 6.5.0
R4760:1cad4e24bc33: Use openjdk-11 for josm
R366:ee4c18aaaf8a: Update maven to 3.6.3
R4992:32155b7d7ffc: Un-bootstrap openjdk-11 and integrate OpenJFX
R365:2440badb9809: Update apache-ant to 1.10.8
R588:f85b76033e21: Update darktable to 3.0.2
R2242:812e4ccaf425: Make openjdk-8 compatible with multiple Java installations
T8804: Update pdfsam to 4.1.1
D7690: Make openjdk-8 compatible with multiple Java installations
T8097: Java 11 LTS - OpenJDK 11 - OpenJRE 11
D5809: Update python-docker-py to 3.7.1
D4696: [RFC] Add support for multiple java versions
T4612: Netbeans IDE
Mentioned Here
D9078: Update ArduinoIDE to 1.8.13
T7235: Update Cryptomator to 1.4.0

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
serebit updated the task description. (Show Details)Jun 6 2020, 8:27 PM
serebit updated the task description. (Show Details)
serebit updated the task description. (Show Details)Jun 6 2020, 8:40 PM
serebit raised the priority of this task from Wishlist to Low.Jun 6 2020, 9:55 PM
serebit updated the task description. (Show Details)
serebit updated the task description. (Show Details)Jun 6 2020, 11:51 PM
serebit updated the task description. (Show Details)Jun 7 2020, 1:29 AM

@serebit Java packages to be deprecated:

  • bfg-repo-cleaner
  • i2p
  • java-service-wrapper
  • kontalk
serebit updated the task description. (Show Details)Jun 7 2020, 3:05 PM
serebit updated the task description. (Show Details)
serebit updated the task description. (Show Details)Jun 8 2020, 1:59 AM
serebit updated the task description. (Show Details)Jun 8 2020, 2:04 AM
serebit updated the task description. (Show Details)
serebit updated the task description. (Show Details)Jun 8 2020, 2:33 AM
serebit updated the task description. (Show Details)Jun 8 2020, 3:03 AM
serebit updated the task description. (Show Details)
serebit updated the task description. (Show Details)
serebit updated the task description. (Show Details)
serebit updated the task description. (Show Details)Jun 12 2020, 10:49 PM
serebit updated the task description. (Show Details)Jun 13 2020, 2:14 AM
serebit updated the task description. (Show Details)Jun 14 2020, 4:41 AM

For anyone following this task, 100% of my patches integrating JDK11 into our Java stack have been pushed to unstable, with the exception of Scala. If you use any of the software in the above checklist (minus the ones under Planned Deprecation), please give it a look and make sure it's working as intended.

serebit updated the task description. (Show Details)Jun 17 2020, 4:40 PM
serebit removed a project: Requires Rebuilds.
serebit updated the task description. (Show Details)Jun 17 2020, 4:56 PM
serebit removed a project: Planned Deprecation.
serebit updated the task description. (Show Details)Jun 17 2020, 5:03 PM
serebit added a project: Requires Rebuilds.
serebit updated the task description. (Show Details)Jun 17 2020, 5:57 PM
serebit updated the task description. (Show Details)Jun 17 2020, 6:07 PM
serebit updated the task description. (Show Details)
serebit updated the task description. (Show Details)Jun 17 2020, 9:58 PM
serebit updated the task description. (Show Details)Jun 17 2020, 10:05 PM
chax added a subscriber: chax.Jun 17 2020, 11:11 PM

Migrated Arduino IDE to JDK 11 in D9078

serebit updated the task description. (Show Details)Jun 18 2020, 12:18 AM
serebit updated the task description. (Show Details)Jun 18 2020, 1:02 AM
chax removed a subscriber: chax.Jun 18 2020, 1:33 AM
serebit updated the task description. (Show Details)Jun 18 2020, 4:09 AM
serebit closed this task as Resolved.Jun 22 2020, 9:47 PM
serebit updated the task description. (Show Details)
serebit removed a project: Requires Rebuilds.