Page MenuHomeSolus

Include patched VBoxOGLrenderspu.so with Virtualbox package that fixes known issue with flickering W10 guests
Closed, InvalidPublic

Description

Not sure if this is something you folks would be willing to do but I figured it's worth asking about.

There is a known issue in VirtualBox that causes Win10 guests to flicker when 3D acceleration is enabled and the host uses Nvidia graphics. Apparently, Virtualbox has to leave it as-is because one of their paying customers needs it this way.. so everyone else has to deal with flickering problems. If it wasn't for that one customer, the patched version would be the default.

Blog post overview: https://techblog.devlat.eu/2017/04/07/screen-flickering-in-virtualbox-with-3d-enabled/
Full situation discussed here: https://www.virtualbox.org/ticket/13653
Official patch here: https://www.virtualbox.org/attachment/ticket/13653/vbox-NVIDIA-fix-v2.patch.txt

It would be nice if the maintainers here could apply this patch to the VBox package distributed in the repo.

Thank you

Event Timeline

Beer created this task.Jul 12 2018, 1:52 PM
JoshStrobl edited projects, added Software; removed Lacks Project.Jul 20 2018, 10:25 AM
JoshStrobl added subscribers: kyrios123, JoshStrobl.

Prodding @kyrios123 to take a look if possible:

Doesn't mean the introduction of this CR_RENDER_FORCE_PRESENT_MAIN_THREAD define is correct (the comment talks about "debugging only"), but it means most likely someone will complain about a regression if this patch goes in. Looks like we have to ask the customer to try with a build where this is removed, to see if they really depend on this change or if the actual fix was elsewhere.

That's from 3 years ago, granted.

JoshStrobl triaged this task as Needs More Info priority.Oct 16 2018, 11:36 PM

So...@kyrios123 :P

looks like I missed that one.

kyrios123 closed this task as Invalid.Oct 17 2018, 1:44 PM

This patch is not required anymore since 81095809e5ee

3D: add environment variable to configure presenting 3D content on main thread (see bug #13653)

Just call virtualbox this way CR_RENDER_FORCE_PRESENT_MAIN_THREAD=0 VirtualBox