Page MenuHomeSolus

Wrong keyboard layout in sddm if user is not logged in
Open, Needs More InfoPublic

Description

sddm keyboard layout is set to ANSI (I think. SHIFT+3 gives #) if user is not logged in. Otherwise it's fine, for example when you wake the screen or the whole PC up from sleeping.
Logging out resets the layout to ANSI.
My layout is UK-extended.

livingsilver94 renamed this task from Wrong keyboard layout is sddm if user is not logged in to Wrong keyboard layout in sddm if user is not logged in .

SDDM doesn't use user preferences...how would it determine which user's settings to use? Or have permissions to read them. The installer sets up your keyboard choices from installation in /etc/X11/xorg.conf.d/00-keyboard.conf

When you wake up your computer, it is not SDDM, but plasma (kscreenlocker) so the users plasma keyboard settings are used.

SDDM doesn't use user preferences...how would it determine which user's settings to use? Or have permissions to read them.

Good point. kscreenlocker and sddm have the same UI. That misled me.

I'll check the file you posted, but I'm pretty sure I chose UK-extended during Solus installation... To be 100% safe I'll install it again on a VM.

Oops, no, I totally forgot about this. Let me immediately install the VM.

livingsilver94 added a comment.EditedAug 5 2018, 10:09 AM

Ok, I've installed Solus on a new VM. UK extended is not set neither in SDDM nor in Plasma. About the latter, I had to remove and re-add the UK layout 'cause the default one (the one set via the installer) was not correctly detected in Keyboard Settings.

Fullscreen screenshot :/

sunnyflunk added a comment.EditedAug 5 2018, 10:14 AM

What was in this file? /etc/X11/xorg.conf.d/00-keyboard.conf

# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbModel" "pc104"
        Option "XkbLayout" "gb+extd"
EndSection

I expect the layouts screen to lack layouts until you add more (the correct layout tends to autofill).

What does localectl report straight after you boot up from the install? I assume the keyboard doesn't work correctly for the intended layout

DataDrake triaged this task as Needs More Info priority.Oct 16 2018, 8:48 PM
JoshStrobl closed this task as Resolved.Mar 1 2019, 9:11 PM
JoshStrobl claimed this task.
JoshStrobl added a subscriber: JoshStrobl.

Closing due to lack of response.

livingsilver94 reopened this task as Open.EditedMar 6 2019, 10:59 PM

I expect the layouts screen to lack layouts until you add more (the correct layout tends to autofill).

What does localectl report straight after you boot up from the install? I assume the keyboard doesn't work correctly for the intended layout

fabio@phoenix ~ $ localectl
   System Locale: LANG=en_US.UTF-8
       VC Keymap: n/a
      X11 Layout: gb+extd
       X11 Model: pc104

I set the UK extended layout during installation AND the US locale.

This is the clearly wrong setting you cansee right after the installation.
This is the correct one, manually set.
JoshStrobl removed JoshStrobl as the assignee of this task.Apr 24 2019, 12:35 PM

Just reinstalled Solus Plasma and I can confirm this bug still exists.

I suspect this is something that must be fixed within the Solus installer.