Page MenuHomeSolus

snap app won't run with linux-lts : snap-update-ns failed with code 1: No such file or directory
Closed, ResolvedPublic

Description

rizvan@solus4 ~ $ mailspring
cannot change profile for the next exec call: No such file or directory
snap-update-ns failed with code 1: No such file or directory

rizvan@solus4 ~ $ uname -r
4.9.107-97.lts

With linux-current it is working. I want to use LTS, so that my system won't be broken with the latest kernel updates. Kindly look into snap and LTS issue. Thank you.

Event Timeline

I think the problem could be with snapd service.

reinstall snapd runs the snap (mailspring snap)

sudo eopkg install snapd --reinstall
ex47 added a subscriber: ex47.Jul 7 2018, 4:13 AM

I have the same problem with minecraft installed with snap.

Use sudo apparmor_parser /var/lib/snapd/apparmor/profiles/* to fix it. It needs to be done every reboot.

Thanks, ex47, it works. mailspring was working fine, but suddenly other snaps stopped working, running apparmor_parser command fixed them all.

LostSouls removed a subscriber: LostSouls.

Same here with hiri snap (exchange mail client).
sudo apparmor_parser... did the trick.

confirmation
Only needed to be done once.

In the meantime on solus plasma I have to do it daily again.

I looked into this and I think I found the solution, to culbrit seems to be this https://forum.snapcraft.io/t/fixing-live-propagation-of-mount-changes/23

I added to the snapd.tmpfiles

d /var/lib/snapd/mount 0755 root root -

and it seems to be fixed and no issues after rebooting but while building I get an abi change inside snapd

-libgcc_s.so.1

gets removed

Dunno if this should happen or something else is wonky, maybe the coreteam can say more

I almost opened another bug report for this issue. I reinstalled snapd and got my snaps running again. They fail to run (apparmor DENIED...) after I reboot or logout. I can reinstall the snap or reinstall snapd but this seems as though it might deserve some further attention.

Running sudo apparmor_parser /var/lib/snapd/apparmor/profiles/* failed to help in my case.

NOTE

This issue is consistent across all my Solus powered machines.

I think the problem could be with snapd service.
reinstall snapd runs the snap (mailspring snap)

sudo eopkg install snapd --reinstall
Girtablulu added a comment.EditedJan 13 2019, 11:20 AM

@kz6fittycent Can you tell me which snap? all my test snaps are starting.

Are you fully updated? to check run inside the terminal sudo eopkg up

Yeah systems are always fully updated.

Which snap?

mc-installer, supertuxkart, makemkv, lolcat-c, htop, & vlc.

So, it's not just one snap, as you can see. It's stopped now that I've reinstalled snapd as indicated above. That's not a "fix", more a workaround.

tjhnst added a subscriber: tjhnst.Feb 27 2019, 12:54 AM

Getting this same issue with snapd and the lxd snap on up-to-date Solus with a 4.20.8-110.current kernel.

Is there a better option than reinstalling snapd and then restarting a bunch of stuff?