Page MenuHomeSolus

Package Requests: Pure Data (Pd)
Closed, DuplicatePublic

Description

  • Name: Pure Data (Pd)
  • Homepage: https://puredata.info/
  • Why should this be included in the repository? Pure Data (or Pd) is a real-time graphical programming environment for audio, video, and graphical processing. Pure Data is commonly used for live music performance, VeeJaying, sound effects, composition, audio analysis, interfacing with sensors, using cameras, controlling robots or even interacting with websites. Because all of these various media are handled as digital data within the program, many fascinating opportunities for cross-synthesis between them exist. Sound can be used to manipulate video, which could then be streamed over the internet to another computer which might analyze that video and use it to control a motor-driven installation. It enables musicians, visual artists, performers, researchers, and developers to create software graphically without writing lines of code. Pd can be used to process and generate sound, video, 2D/3D graphics, and interface sensors, input devices, and MIDI. Pd can easily work over local and remote networks to integrate wearable technology, motor systems, lighting rigs, and other equipment. It is suitable for learning basic multimedia processing and visual programming methods as well as for realizing complex systems for large-scale projects. More info here. Extended list of libraries here.
  • How many users do you anticipate will use this software? This program has been in use by multimedia artists for ages and probably has no equivalent in Linux (FOSS or not, as Max currently has no Linux offering). I think it could draw this crowd to Solus.
  • Is it open source? Yes
  • Tarball: http://msp.ucsd.edu/Software/pd-0.48-1.src.tar.gz

The repository can be found here and here. Useful info for building it here.

Event Timeline

pierrebonbon updated the task description. (Show Details)Jun 5 2018, 9:57 AM
DataDrake closed this task as a duplicate of T2363: puredata.Jun 5 2018, 10:06 AM

@DateDrake How did I missed this? My apologies!