Page MenuHomeSolus

Enable Support for Sierra AirPrime EM7455 LTE card
Closed, ResolvedPublic

Description

Sierra AirPrime EM7455 is a common LTE card for Dell, Lenovo, and other laptops.

I have one in my Thinkpad 470s.

It is supported in kernel 4.7+ and by ModemManager.

However it does not appear in Solus Budgie.

Here is my hardware information:

https://gist.github.com/sirredbeard/9baf843910e147f871894d701ce65660

Event Timeline

$ lsusb
Bus 002 Device 004: ID 17ef:1010 Lenovo 
Bus 002 Device 003: ID 0bda:0316 Realtek Semiconductor Corp. 
Bus 002 Device 002: ID 154b:fa05 PNY Flash Drive
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 5986:111c Acer, Inc 
Bus 001 Device 005: ID 8087:0a2b Intel Corp. 
Bus 001 Device 003: ID 1199:9079 Sierra Wireless, Inc. 
Bus 001 Device 009: ID 17ef:100f Lenovo 
Bus 001 Device 008: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 006: ID 1bcf:0005 Sunplus Innovation Technology Inc. Optical Mouse
Bus 001 Device 004: ID 04d9:a0cd Holtek Semiconductor, Inc. 
Bus 001 Device 002: ID 17ef:1010 Lenovo 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 001 Device 003: ID 1199:9079 Sierra Wireless, Inc.

qcserial 20480 0 - Live 0xffffffffa03ed000

So it's detected and loads the module (it 2. above), the issue is somewhere within MM/NM/hardware detection.

JoshStrobl moved this task from Backlog to Networking on the Hardware board.Jul 29 2018, 4:19 PM

I imagine this was solved months ago if you are willing to test it.

DataDrake closed this task as Resolved.Oct 16 2018, 9:59 PM
DataDrake claimed this task.
DataDrake added a subscriber: DataDrake.

Tentatively marking this as resolved. Please reopen if it is still a problem after latest updates.