Page MenuHomeSolus

Xbox controller is not detected by steam
Closed, ResolvedPublic

Description

My xbox controller does not get detected by steam anymore (dunno when this happened for me)

lsubs : Bus 003 Device 012: ID 045e:02d1 Microsoft Corp. Xbox One Controller

Does find it but xboxdrv doesn't even if I point xboxdrv directly on the device over or general looking for it no success

Event Timeline

Girtablulu edited projects, added Hardware; removed Lacks Project.May 28 2018, 11:13 AM

As it seems, it's since the last stable sync

@Girtablulu Few things are of interest to me:

  • Any difference if booting into the older 4.15 kernel
  • lsmod | egrep -E "uinput|joydev"
  • ls -al /dev/uinput
  • Assume sudo xboxdrv doesn't have this issue?

I do not have kernel 4.15 anymore on my PC, would need to reinstall it

[11:28:30] ⇛ [~] 
>>> # lsmod | egrep -E "uinput|joydev"
joydev                 24576  0
[11:29:01] ⇛ [~] 
>>> # ls -al /dev/uinput
crw-rw----+ 1 root root 10, 223 29. Mai 09:27 /dev/uinput

sudo xboxdrv does not find my controller as well
sunnyflunk added a comment.EditedMay 30 2018, 1:58 AM

Can you try applying these udev rules (they look slightly different):

https://steamcommunity.com/app/353370/discussions/0/490123197956024380/

Then run sudo usysconf run udev-rules -f

Also confirm the HID kernel module is loaded

lsmod | grep hid

did not work and hid modules are loaded

Last thing, get the dmesg output of the device, (will show some really long line something like /devices/pci0000:00/0000:00:14.0/usb1/1-7/1-7:1.0/bluetooth/hci0/hci0:256/0005:054C:0268.0007/input/input22)

I want to see the permissions on that - you'll need to run ls -al /sys/${DEVICES_LINE_FROM_DMESG}

Girtablulu added a comment.EditedMay 30 2018, 8:31 PM
[22:30:33] ⇛ [~] 
>>> # ls -ak /sys/${devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3.3/3-3.3:1.0/input/input24}
.  ..  block  bus  class  dev  devices  firmware  fs  kernel  module  power
Girtablulu added a comment.EditedMay 31 2018, 9:39 AM
sudo ls -al /sys/devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3.3/3-3.3:1.0/input/input23
insgesamt 0
drwxr-xr-x 7 root root    0 31. Mai 12:05 .
drwxr-xr-x 3 root root    0 31. Mai 12:05 ..
drwxr-xr-x 2 root root    0 31. Mai 12:05 capabilities
lrwxrwxrwx 1 root root    0 31. Mai 12:05 device -> ../../../3-3.3:1.0
drwxr-xr-x 3 root root    0 31. Mai 12:05 event16
drwxr-xr-x 2 root root    0 31. Mai 12:05 id
drwxr-xr-x 3 root root    0 31. Mai 12:05 js0
-r--r--r-- 1 root root 4096 31. Mai 12:05 modalias
-r--r--r-- 1 root root 4096 31. Mai 12:05 name
-r--r--r-- 1 root root 4096 31. Mai 12:05 phys
drwxr-xr-x 2 root root    0 31. Mai 12:05 power
-r--r--r-- 1 root root 4096 31. Mai 12:05 properties
lrwxrwxrwx 1 root root    0 31. Mai 12:05 subsystem -> ../../../../../../../../../class/input
-rw-r--r-- 1 root root 4096 31. Mai 12:05 uevent
-r--r--r-- 1 root root 4096 31. Mai 12:05 uniq

next try with being less tired :D

Well the ultimate test would be to roll back the systemd update, but it's a hard thing to recommend someone to do without feeling a bit comfortable with system recovery.

Or even just replace the /usr/lib/udev files with the ones from the old package.

I'll giving it a try now.

Can have a look at it later this evening sunnyflunk

bwat47 added a subscriber: bwat47.EditedJul 15 2018, 11:57 AM

I have an xbox one controller and was having the same problem.

For me, disabling 'Use native runtime' fixes it, Steam now detects my controller

Can confirm, after I switched it off steam detects it

@Girtablulu I have backported a patch which to me seems to be the most likely culprit https://dev.solus-project.com/R2866:9eaeb4ed53305b50d19d34eb2221d4fce9104d10 Can you test this one out and confirm whether installing the unstable sdl2 and sdl2-32bit packages still results in a working gamepad?

@sunnyflunk can confirm, with LSI it detects now my steam controller but if I have deactivated it it won't . I rebooted my PC after updating

sunnyflunk closed this task as Resolved.Aug 7 2018, 10:57 AM
sunnyflunk claimed this task.

@Girtablulu has confirmed on IRC this is now working on unstable, with and without the steam runtime active. Will need to update after sync and reboot.