Page MenuHomeSolus

Installing Steam creates multiple menu entries in Budgie and MATE
Closed, WontfixPublic

Description

After installing the Steam 1.0.0.54 package from the Solus repo two icons appear in the Budgie Menu, one called "Steam" and one called "Steam Linux Integration".

Is also creates a duplicate "Internet" category in which the two icons appear.

Telegram 1.2.17-85 also appears in the duplicate "Internet" category".

Event Timeline

telegram.desktop from /usr/share/applications

steam.desktopm from ~/.local/share/applications/

lsi-settings from " "

sirredbeard added a comment.EditedMay 16 2018, 5:30 AM

The temporary workaround is to hide the duplicate entries using alacarte.

Note menulibre is in the Solus repo as well but it didn't really work. Menulibre was built with Ubuntu in mind. alacarte is much easier to use and is part of the official gnome software ecosystem.

Please check the welcome message ?

Jacalz added subscribers: ikey, Jacalz.EditedMay 16 2018, 9:19 AM

Linux steam integration is no duplicate, it is a tool made by @ikey to get better game support on Linux! If you open Linux steam integration you will see settings there for how you want it to work ? @sirredbeard But the duplicate internet entries are definitely a problem in my opinion ?

Please check the welcome message ?

I am not sure what I missed from the welcome message. Could you please elaborate? I am new here. I have reproduced this bug across Solus Budgie and Solus MATE and was unable to duplicate on Ubuntu Budgie or Fedora Budgie, so if you are referring to filing Budgie-specific reports on the Budgie GitHub, this appeared to be more of a Solus distro issue.

Linux steam integration is no duplicate, it is a tool made by @ikey to get better game support on Linux! If you open Linux steam integration you will see settings there for how you want it to work ? @sirredbeard But the duplicate internet entries are definitely a problem in my opinion ?

Yes, I should have been more clear and I apologize for the confusion. I understand that Steam and LSI are two different packages. Steam and LSI are duplicative in that they appear multiple times in the main Budgie menu when searching "Steam" and they create a duplicative "Internet" entry on the panel to the left. I heard Ikey talking about reducing duplicates on a Destination Linux episode, I am not sure if that is working correctly or perhaps Steam and LSI just need tweaked .desktop files. Thank you again.

DataDrake closed this task as Wontfix.Jul 29 2018, 4:19 PM
DataDrake claimed this task.
DataDrake added a subscriber: DataDrake.

They may show up in multiple categories. That is intended. But there aren't any actual duplicate entries in a search or under "All"