Page MenuHomeSolus

GUI video jumbled after recent update on Solus guest in VirtualBox
Closed, ResolvedPublic

Description

I installed Solus Budgie in VirtualBox 5.12.2 using the Solus Budgie ISO from the website.

Install and reboot worked fine.

Software updated showed several hundred updates available, I updated, then restarted.

On restart when the GUI login loads the video display is messed up.

The system is not locked up, I can log in actually, but the video display is just all janky.

Some people like myself might be interested in trying Solus in a VM before switching.

VirtualBox is a pretty popular VM tool, it's components are used in other VM implementations.

It might be worth looking to see if a video driver update is breaking Solus in VirtualBox.

Thank you.

Here is my .vbox file for examination.

sirredbeard renamed this task from Solus Budgie update breaks testing in VirtualBox to GUI video jumbled after recent update on Solus guest in VirtualBox.May 12 2018, 3:23 AM
sirredbeard updated the task description. (Show Details)
sirredbeard removed a project: Lacks Project.
sirredbeard updated the task description. (Show Details)
sirredbeard added a project: Triage Team.

There is the log from VirtualBox up until the point the GUI loads and the video is jumbled.

These are the packages getting upgraded:

linux@virtualbox ~ $ sudo eopkg upgrade -v
Updating repositories
Updating repository: Solus
Fetching https://packages.solus-project.com/shannon/eopkg-index.xml.xz.sha1sum
eopkg-index.xml.xz.sha1sum (40.0 B)100% 709.26 KB/s [00:00:00] [complete]
Solus repository information is up-to-date.
Package spidermonkey is not available in repositories.
Package libimobiledevice is already at the latest release 5.
Package npth is already at the latest release 3.
Package fftw is already at the latest release 7.
Package dejavu-fonts-ttf is already at the latest release 4.
Package libnl is already at the latest release 3.
Package dosfstools is already at the latest release 8.
Package inotify-tools is already at the latest release 2.
Package ntfs-3g is already at the latest release 10.
Package font-droid-ttf is already at the latest release 6.
Package openconnect is already at the latest release 4.
Package grub2 is already at the latest release 18.
Package libvdpau is already at the latest release 8.
Package pcaudiolib is already at the latest release 3.
Package xcb-util-renderutil is already at the latest release 2.
Package xcb-util-wm is already at the latest release 3.
Package xauth is already at the latest release 3.
Package libedit is already at the latest release 2.
Package libwpg is already at the latest release 1.
Package kbd is already at the latest release 2.
Package gpart is already at the latest release 1.
Package mythes is already at the latest release 1.
Package libpaper is already at the latest release 3.
Package squashfs-tools is already at the latest release 6.
Package lzo is already at the latest release 3.
Package reiserfsprogs is already at the latest release 2.
Package vpnc is already at the latest release 3.
Package xdpyinfo is already at the latest release 3.
Package font-lateef-ttf is already at the latest release 1.
Package uchardet is already at the latest release 1.
Package font-indic-ttf is already at the latest release 1.
Package sbc is already at the latest release 1.
Package gutenprint is already at the latest release 3.
Package orc is already at the latest release 5.
Package libgpod is already at the latest release 1.
Package xmodmap is already at the latest release 5.
Package isl is already at the latest release 1.
Package librest is already at the latest release 7.
Package gpm is already at the latest release 2.
Package docbook-xml is already at the latest release 7.
Package python-pycurl is already at the latest release 5.
Package libplist is already at the latest release 6.
Package xcb-util-image is already at the latest release 2.
Package groff is already at the latest release 2.
Package tree is already at the latest release 2.
Package liblangtag is already at the latest release 1.
Package libcroco is already at the latest release 8.
Package libspectre is already at the latest release 2.
Package which is already at the latest release 3.
Package pixman is already at the latest release 10.
Package wireless-tools is already at the latest release 3.
Package libcddb is already at the latest release 1.
Package cups-pk-helper is already at the latest release 4.
Package gcab is already at the latest release 2.
Package xrandr is already at the latest release 4.
Package libmwaw is already at the latest release 4.
Package xinit is already at the latest release 4.
Package python-urlgrabber is already at the latest release 5.
Package popt is already at the latest release 6.
Package python-magic is already at the latest release 3.
Package cpio is already at the latest release 10.
Package bash-completion is already at the latest release 11.
Package libnotify is already at the latest release 5.
Package dotconf is already at the latest release 1.
Package comar-api is already at the latest release 5.
Package xdg-user-dirs-gtk is already at the latest release 4.
Package libodfgen is already at the latest release 1.
Package libaio is already at the latest release 2.
Package piksemel is already at the latest release 2.
Package cyrus-sasl is already at the latest release 7.
Package libnettle is already at the latest release 15.
Package libgnome-menus is already at the latest release 10.
Package libxkbcommon is already at the latest release 5.
Package libcap2 is already at the latest release 6.
Package hyphen is already at the latest release 1.
Package sound-theme-freedesktop is already at the latest release 2.
Package libssh2 is already at the latest release 5.
Package font-tlwg-ttf is already at the latest release 1.
Package cracklib is already at the latest release 6.
Package procps-ng is already at the latest release 6.
Package graphite2 is already at the latest release 4.
Package libmad is already at the latest release 3.
Package libselinux is already at the latest release 1.
Package fdk-aac is already at the latest release 1.
Package goofiboot is already at the latest release 3.
Package libsecret is already at the latest release 11.
Package twolame is already at the latest release 2.
Package font-roboto-ttf is already at the latest release 4.
Package pinentry is already at the latest release 5.
Package openldap is already at the latest release 5.
Package comar is already at the latest release 5.
Package liblcms2 is already at the latest release 7.
Package libgtkmm-2 is already at the latest release 6.
Package alsa-firmware is already at the latest release 3.
Package neon is already at the latest release 3.
Package libdmx is already at the latest release 7.
Package python-pyliblzma is already at the latest release 2.
Package vo-aacenc is already at the latest release 1.
Package libusbmuxd is already at the latest release 2.
Package swig is already at the latest release 3.
Package espeak-ng is already at the latest release 2.
Package cogl is already at the latest release 13.
Package ijs is already at the latest release 1.
Package setxkbmap is already at the latest release 3.
Package libssh is already at the latest release 3.
Package psmisc is already at the latest release 1.
Package bc is already at the latest release 5.
Package libsigc++ is already at the latest release 8.
Package xcb-util-keysyms is already at the latest release 2.
Package stoken is already at the latest release 2.
Package disktype is already at the latest release 4.
Package opus is already at the latest release 7.
Package nghttp2 is already at the latest release 2.
Package libshout is already at the latest release 2.
Package libtheora is already at the latest release 5.
Package libieee1284 is already at the latest release 2.
Package libndp is already at the latest release 3.
Package libdmapsharing is already at the latest release 1.
Package libtool is already at the latest release 8.
Package readline is already at the latest release 5.
Package mobile-broadband-provider-info is already at the latest release 3.
Package coinmp is already at the latest release 2.
Package libksba is already at the latest release 5.
Safety switch forces the installation of following packages:
aa-lsm-hook audit libgudev qol-assist usysconf
Safety switch forces the upgrade of following packages:
acl attr baselayout bash ca-certs
clr-boot-manager coreutils cryptsetup curl db5
dbus dbus-glib e2fsprogs expat file
findutils gawk gettext gmp gobject-introspection
grep gzip hwdata inetutils iso-codes
jansson kernel-glue kmod less libgcrypt
libgomp libgpg-error libgusb libnspr libnss
libpipeline libusb libxml2 libxslt linux-driver-management
lvm2 lz4 lzip mpc mpfr
ncurses openssl pam pisi polkit
python python-dbus sed shadow sharutils
sqlite3 sudo tar time tzdata
unzip usbutils xz zip
The following packages will be upgraded:
aa-lsm-hook aalib
accountsservice acl
adapta-gtk-theme adwaita-icon-theme
alsa-lib alsa-plugins
alsa-utils apparmor
appstream-data appstream-glib
at-spi2 at-spi2-atk
atkmm attr
audit avahi
baobab baselayout
bash bash-recovery
bind-utils binutils-libs
bluez breeze-cursor-theme
bubblewrap budgie-desktop
budgie-desktop-branding budgie-desktop-branding-material
bzip2 ca-certs
cairomm canon-ufriilt-common
clr-boot-manager clutter
clutter-gtk colord
coreutils cryptsetup
cups cups-filters
curl db5
dbus dbus-glib
dbus-launch dconf
dconf-editor desktop-file-utils
dhclient djvulibre
dmidecode doflicky
dracut e2fsprogs
enchant eog
evince evolution-data-server
exfat-utils exiv2
expat faad
ffmpeg file
file-roller findutils
firefox font-clear-sans-ttf
font-hack-ttf font-symbola-ttf
fontconfig foomatic-db
foomatic-db-engine freeglut
freetype2 freetype2-subpixel
fribidi fuse
fuse-exfat gawk
gconf gcr
gd gdbm
gdk-pixbuf gedit
geoclue gettext
gexiv2 ghostscript
giflib glib-networking
glib2 glibc
glibmm gmime
gmp gnome-autoar
gnome-backgrounds gnome-bluetooth
gnome-calculator gnome-calendar
gnome-color-manager gnome-control-center
gnome-disk-utility gnome-doc-utils
gnome-keyring gnome-mpv
gnome-online-accounts gnome-screensaver
gnome-screenshot gnome-session
gnome-settings-daemon gnome-system-monitor
gnome-terminal gnome-themes-standard
gnome-user-docs gnupg
gobject-introspection gparted
gpgme gptfdisk
grep grilo
gsettings-desktop-schemas gspell
gstreamer-1.0 gstreamer-1.0-libav
gstreamer-1.0-plugins-bad gstreamer-1.0-plugins-base
gstreamer-1.0-plugins-good gstreamer-1.0-plugins-ugly
gvfs gvfs-goa
gzip harfbuzz
hexchat hicolor-icon-theme
hplip-drivers hunspell-en
hwdata ibus
ilmbase imagemagick
imlib2 inetutils
inxi iproute2
iptables iso-codes
jansson jasper
kerberos kernel-glue
kmod lame
ldb less
liba52dec libabw
libao libarchive
libass libassuan
libatasmart libatk
libblockdev libbluray
libboost libbytesize
libcaca libcairo
libcanberra libcdio
libcdio-paranoia libcdr
libcmis libcolord-gtk
libcue libdaemon
libdazzle libdrm
libdv libdvdcss
libdvdnav libdvdread
libe-book libelf
libepoxy libetonyek
libevdev libevent
libexempi libexif
libexttextcat libffi
libflac libfontenc
libfreehand libgcc
libgcrypt libgdata
libgeocode-glib libglade
libglu libglvnd
libgnome-desktop libgnomekbd
libgnutls libgomp
libgpg-error libgphoto2
libgrss libgsf
libgtk-2 libgtk-3
libgtkmm-3 libgtksourceview
libgtop libgudev
libgusb libgweather
libgxps libhunspell
libical libice
libicu libinput
libiptcdata libixion
libjpeg-turbo libjson-glib
libkate libmbim
libmpeg2 libmspub
libmtp libnfs
libnice libnspr
libnss liboauth
libogg liborcus
libosinfo libp11-kit
libpagemaker libparted
libpciaccess libpcre
libpeas libpipeline
libpng libproxy
libpwquality libqmi
libquvi libqxp
libraw libreoffice-calc
libreoffice-common libreoffice-draw
libreoffice-impress libreoffice-writer
librevenge librsvg
libseccomp libsm
libsndfile libsoup
libsoxr libspeex
libstartup-notification libstdc++
libtasn1 libtelepathy-glib
libtiff libtimezonemap
libunistring libunwind
libusb libva
libvisio libvoikko
libvorbis libvpx
libvte libwacom
libwebkit-gtk libwebp
libwnck libwpd
libwps libx11
libxau libxcb
libxcomposite libxcursor
libxdamage libxdmcp
libxext libxfixes
libxfont libxfont2
libxft libxi
libxinerama libxkbfile
libxklavier libxml2
libxmu libxpm
libxrandr libxrender
libxres libxscrnsaver
libxshmfence libxslt
libxt libxtst
libxv libxxf86dga
libxxf86vm libzmf
lightdm linux-current
linux-driver-management linux-driver-management-lightdm-integration
linux-firmware linux-tools-cpupower
llvm lsb-release
lsof lua
lua51 luajit
lvm2 lz4
lzip man-db
mariadb-libs mdadm
mesa-demos mesalib
mjpegtools-libs modem-manager
mozjs38 mpc
mpfr mpg123
mpv-libs mtdev
mutagen mutter
nano nautilus
nautilus-extension ncurses
net-snmp network-manager
network-manager-applet networkmanager-openconnect
networkmanager-openvpn noto-sans-ttf
nss-mdns nvidia-304-glx-driver-modaliases
nvidia-340-glx-driver-modaliases nvidia-glx-driver-modaliases
onboard openal-soft
openexr openjpeg
openssh openssl
openvpn orca
os-prober osinfo-db
pam pango
pangomm papirus-icon-theme
parted pciutils
pcre2 perl
perl-net-dbus perl-x11-protocol
perl-xml-twig perl-xmlparser
pisi polkit
poppler poppler-data
poppler-utils pulseaudio
pyatspi2 pycups
pyparsing python
python-appdirs python-asn1
python-asn1crypto python-cairo
python-certifi python-cffi
python-chardet python-cparser
python-cryptography python-dbus
python-enum34 python-geoip
python-gobject python-idna
python-ipaddress python-openssl
python-packaging python-parted
python-pysmbc python-pysocks
python-requests python-setuptools
python-six python-urllib3
python3 python3-cairo
python3-dbus python3-gobject
qol-assist qpdf
qt5-base qtstyleplugins
rhythmbox rhythmbox-alternative-toolbar
samba sane-backends
sdl1 sdl2
seahorse sed
shadow shared-mime-info
sharutils slick-greeter
snapd snappy
sndio solus-artwork
solus-hardware-config solus-sc
speech-dispatcher sqlite3
sudo system-config-printer
systemd taglib
talloc tar
tdb tevent
thunderbird time
totem-pl-parser tracker
tracker-miners transmission
tzdata udisks
unicode-character-database unixodbc
unrar unzip
upower usbutils
usysconf util-linux
v4l-utils vapoursynth
vino volume_key
vulkan wavpack
wayland wget
wpa_supplicant x264
x265 xcb-util
xdg-user-dirs xdg-utils
xkbcomp xkeyboard-config
xmlsec1 xorg-driver-input-libinput
xorg-driver-input-wacom xorg-driver-video-amdgpu
xorg-driver-video-fbdev xorg-driver-video-nouveau
xorg-driver-video-qxl xorg-driver-video-radeon
xorg-driver-video-vesa xorg-driver-video-vmware
xorg-server xset
xvidcore xz
yelp yelp-xsl
youtube-dl zenity
zimg zip
zlib
Total size of package(s): 864.56 MB
There are extra packages due to dependencies.

This does appear to be reproducible. I installed the above in the Solus guest, rebooted, and then got this:

On the guest machine.

Switch to tty1 then back to tty7 and you should see the desktop. If not just log in on tty1.

Then sudo eopkg it virtualbox-guest-current

sirredbeard closed this task as Resolved.

Running:

sudo eopkg it virtualbox-guest-current

Immediately after:

sudo eopkg upgrade

And then rebooting.

Or on reboot switching to tty1 as recommended above and then installing virtualbox-guest-current fixes this issue.

Thank you.