Page MenuHomeSolus

Stuck login
Closed, ResolvedPublic

Description

After I updated Solus (budgie) today, I have a very long login time (after the user select screen).
It takes about 2 mins to login, where before the update it took 1 sec.

I tried to make a new test user (with useradd command), but that wont login at all, it just goes back to the welcome screen, after a brief blackout.

Event Timeline

Kyro created this task.May 5 2018, 8:47 AM
Kyro closed this task as Resolved.May 5 2018, 9:39 AM
Kyro claimed this task.

Seems to be working now, I downloaded 1 update (unzip update?).

Logged in without any delay.

Kyro reopened this task as Open.May 5 2018, 8:45 PM

No, the problem is still there.

But... if I move the mouse after typing in my password, it successfully logs in.

Same issue with me. I found that if I press 'esc' key while 'little wheel' is spinning, the login field returns. I re-enter password again, press 'esc' again, 3rd time entering password then successful login immediately.

RickRNF renamed this task from Slow login to Stuck login.May 6 2018, 6:22 PM
RickRNF added a subscriber: RickRNF.

Happens with Gnome also.

Logging in gets stuck until moving the mouse.

So this morning (5 ins prior to this post) I was able to log in immediately without delay. Performed a full shut down and powered on, able to login in successfully immediately once again.

RickRNF closed this task as Resolved.May 7 2018, 2:34 AM

One of the updates today fixed the issue for me. Perhaps the Nvidia driver update?

DataDrake reopened this task as Open.May 7 2018, 4:02 AM
DataDrake added a subscriber: DataDrake.

Leaving open until the actual Author of this task says the problem is resolved. Thanks!

Kyro added a comment.May 7 2018, 2:14 PM

There has been released an update/downgrade to both the Nvidia driver and the kernel.

I don't think it's a problem with the Nvidia driver, since I tried to uninstall the driver and use the open source one and still had the same problem.

But the linux kernel has been downgraded and it now seem to work, I do not have any delay logging into Solus (testet it 4 times, rebooting after each login).

Right now I can select between 4.15.18-67 (works) and 4.16.7.-66 (can't boot, maybe Nvidia driver problem?)

I can also confirm that 4.15-18-67 boots fine, 4.16.7-66 problem persists.

Snuggle added a subscriber: Snuggle.EditedMay 8 2018, 3:57 AM

I haven't had any issues on either kernel version.

Currently using Budgie w/ NVIDIA 396.24 drivers on my EVGA GTX 960.


I have intentionally deferred the downgrade to 4.15.18-67 because the newer kernel, 4.16.7-66, performs without any issue for me.

maverick1 added a subscriber: maverick1.EditedMay 8 2018, 5:37 AM

Couldn't boot properly from 4.15.18.
The computer booted but stuck showing a screen full of errors. when i pressed enter it took me to tty screen.
But when I changed it to 4.15.17 it worked.
Please solve this issue.

@maverick1 Can you please provide system specs? Processor, Graphics card etc.?

Dell inspiron i7 Radeon r7 graphics

DataDrake removed Kyro as the assignee of this task.Jun 16 2018, 11:54 PM

Is this still an issue on 4.17?

DataDrake triaged this task as Needs More Info priority.Jul 21 2018, 3:22 AM

I haven't experienced this issue for some time.
Currently running:
Kernel: 4.17.6-82.current
DE: Budgie
CPU: Intel i7-4700MQ (8) @ 3.400GHz

Kyro added a comment.Jul 21 2018, 9:05 AM

Been working fine for awhile now.

DataDrake closed this task as Resolved.Jul 21 2018, 12:13 PM
DataDrake claimed this task.

Thanks!