Page MenuHomeSolus

paramiko-2.0.2-1-1
Closed, InvalidPublic

Description

python3-paramiko

python-paramiko

git format-patch

python-paramiko

python3-paramiko

Related Objects

StatusAssignedTask
ResolvedNone
ResolvedJoshStrobl
InvalidNone

I'm not familiar enough with Python, I'm assuming that because this library works with Python 2.6+ and 3.3+, there should be "paramiko" (python3), and "paramiko-python2" packages?

kminehart updated the task description. (Show Details)Sep 14 2016, 1:14 PM

Updated it to use the conventional names. python-paramiko is for python2, python3-paramiko is for python3.

You need to provide git-formatted patches for inclusion in the repo. Providing package.yml and pspec isn't acceptable. See: https://wiki.solus-project.com/Building_packages#Submitting_the_Package

kminehart updated the task description. (Show Details)Sep 19 2016, 1:52 PM

I've updated it to include the git format-patch files. Let me know how it looks.

Actually give me a minute to add the dependencies.

Any reason why these are two separate packages rather than just using both the python and python3 actionable macros consecutively, especially considering they're using the same tarball.

You also don't need to specify python-devel, python, and then python-setuptools, nor python3 then python3-devel. python-setuptools is all you should need for the python2 stuff and you don't need to specify both python3 and python3-devel. Look at what python3-devel depends on.

You're also need to use pkgconfigs, not the package name, where possible. We specify this under the Provides section via eopkg info.

Any update on this @kminehart?

JoshStrobl closed this task as Invalid.Oct 30 2016, 12:11 AM

Closed due to inactivity.