Page MenuHomeSolus

3/4 White Screen with RX580 and Solus Plasma
Closed, ResolvedPublic

Description

I just performed a fresh install with the latest Patreon ISO of Solus Plasma (UEFI). After installation, boot up goes fine (except my motherboard boot screen is deceased in resolution for some odd reason, no other disto did this). I login to SDDM and run updates through the software center. After updating, I reboot and run into a weird issue which breaks the system. SDDM is now rendering 7/8 of the screen white with the login box visible. Mouse and keyboard work, so I login and the desktop is 2/3 white with any app rendering in the "white region" suffering from distortions. I can confirm Solus is fully updated. I repeated with two fresh installations leading to the same results after updating. For reference, Antergoes/Plasma fully updated works just fine on this hardware. Kernel/Xorg/Mesa?

Hardware/Software:
OS: Solus Plasma Beta (update)
RAM 16GB DDR3
Processor: i5-4770K
GPU: MSI RX 580 8GB (using mesa)
Motherboard: Gigabyte GA-Z97X-UD5H-BK
Storage: 256 GB SSD

I am away from the machine, so I don't have any logs to add yet. What would be most helpful (and where might it be located)?

-Numeric


Event Timeline

Numeric created this task.Mar 23 2018, 3:03 PM
Numeric updated the task description. (Show Details)Mar 23 2018, 3:07 PM

Well the obvious first test would be updating to new llvm/mesa and kernels when they are released.

A couple more data points, I did a fresh install with the Budgie iso, same thing happened. I was doing some reading. Back in Solus Roundup #4, it was announced that AMDGPU DC was too be enabled by default for Solus's 4.15 kernel. I attempted to disable it with the following boot parameters, but nothing changed:

echo 'radeon.si_support=1 radeon.cik_support=1 amdgpu.si_support=0 amdgpu.cik_support=0' | sudo tee /etc/kernel/cmdline
sudo clr-boot-manager update

Thoughts? If it is AMDGPU DC, should I just wait for 4.16 to land in Solus's repos?

Thanks,
Numeric

Not just a plasma issue. Broken in budgie too T5867

Can you test to add intel_iommu=off to your kernel parameters? That solved the problem for me.

@stigarn
Yes, running the following removed my distortion. I only rebooted once, but I will continue test and see if the fix holds true. Thank you.

echo 'intel_iommu=of' | sudo tee /etc/kernel/cmdline
sudo clr-boot-manager update

@stigarn
Yes, running the following removed my distortion. I only rebooted once, but I will continue test and see if the fix holds true. Thank you.

echo 'intel_iommu=of' | sudo tee /etc/kernel/cmdline
sudo clr-boot-manager update

No problem. Hope this gets fixed soon so that we don't need to add kernel parameters to get things to work :)

Does this still persist with the new mesa update?

Does this still persist with the new mesa update?

Yes, at least in Budgie, running all the latest updates and the problem still persist.

jtl added a subscriber: jtl.Jul 14 2018, 9:23 PM

Hi.

I'm not running Solus (running Void Linux) but I'm facing a similar issue with amdgpu on a 2015 Macbook Pro with the white screen after login.

https://forum.voidlinux.eu/t/2015-macbook-pro-with-amd-graphics-graphical-screen-corruption-in-xorg/6136/2

Just tried upgrading to the new 4.17 kernel today and still facing this issue.

I will try the kernel cmdline parameter later/

jtl added a comment.Jul 15 2018, 4:02 AM

I can confirm intel_iommu=off fixes the white screen issue under Void, although there are some GPU fault errors in dmesg from amdgpu.

DataDrake closed this task as Resolved.Oct 16 2018, 5:31 PM
DataDrake claimed this task.
DataDrake added a subscriber: DataDrake.

Marking as resolved since a workaround was found.