Page MenuHomeSolus

rd.luks.uuid disappeared from boot options after update
Closed, InvalidPublic

Description

I run Solus with LVM on LUKS on two laptops. After this weeks update rd.luks.uuid boot option disappeared from both the old and the new kernel entries on my work laptop making it unbootable. After adding it explicitly to /etc/kernel/cmdline and running clr-boot-manager update the option was added back. Note that on this laptop Solus is the only OS and was installed to use the whole disk with LUKS enabled during installation. On my personal laptop I also use LVM on LUKS but it was encrypted manually (installed to plain partition on an external drive and than moved into an existing LVM on LUKS container adjusting the boot loader entry accordingly). With the last update boot entries were updated correctly on it, rd.luks.uuid wasn't lost.

I'm not quite sure if it's a corner case in clr-boot-manager update or something weird happened during the update. Let me know how I can provide more useful information to help to resolve the issue.

Event Timeline

raindev created this task.Mar 21 2018, 7:32 PM

Not sure if it's important at all but on my work laptop (the one experiencing the issue) I'm running Solus Mate and on my personal (the one going smoothly through the update) I run Solus GNOME.

I have tried to remove /etc/kernel/cmdline.d/ file with rd.luks.uuid and to run clr-boot-manager update: the boot option disappeared. So the issues is consistently reproducible on one of my laptops (but not the other). The one having issues is a ThinkPad X1 with an NVMe drive and the one don't having the problem is a MacBook Pro with a PCIe SSD.

JoshStrobl edited projects, added Software; removed Lacks Project.Jul 20 2018, 12:22 PM
JoshStrobl added a subscriber: JoshStrobl.

Can't reproduce this issue on my laptop (which is fully encrypted).

DataDrake triaged this task as Needs More Info priority.Oct 16 2018, 5:32 PM
DataDrake added a subscriber: DataDrake.

Is this still an issue?

I got rid of the work laptop since then and hadn't had any issues with my personal laptop. It's probably not possible to figure out what have happened at this point.

DataDrake closed this task as Invalid.Oct 16 2018, 6:48 PM

Marking as invalid since the hardware is no longer available for testing.