Page MenuHomeSolus

MakeMKV doen't see any suitable drives
Closed, LockedPublic

Description

After launching MakeMKV, it says "The program can't find any usable optical drives. Loading the "sg" module (ie, running sudo modprobe sg) resolves the issue. This appears to be with the latest version of MakeMKV. The author has said that the module needs to be loaded in the current and all future versions.

Event Timeline

Contributor added a subscriber: Contributor.

Works perfectly for me. Thank you for sharing!

kz6fittycent added a subscriber: kz6fittycent.EditedApr 25 2018, 9:42 PM

I can confirm this issue & workaround.

MakeMKV v1.12.0 linux(x64-release) started
Debug logging enabled, log will be saved as /home/kz6fittycent/MakeMKV_log.txt
DEBUG: Code 2 at RA.^GiljMK9I.=<EN3!/0ZH#:121261428
The program can't find any usable optical drives.

Basic Info:

Intel® Core™ i7-4790 CPU @ 3.60GHz × 8 
Intel® Haswell Desktop
RAM 15.6 GiB
Gnome 3.26.2
Kernel 4.15.17-65.current

DVD Drive

dmesg | egrep -i --color 'cdrom|dvd|cd/rw|writer'
[    1.161264] ata3.00: ATAPI: hp      DVD A  DS8ACSH, LHS3, max UDMA/133
[    1.164113] scsi 2:0:0:0: CD-ROM            hp       DVD A  DS8ACSH   LHS3 PQ: 0 ANSI: 5
[    1.224986] sr 2:0:0:0: [sr0] scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[    1.224987] cdrom: Uniform CD-ROM driver Revision: 3.20

------------------------------------------------------------------------------

more /proc/sys/dev/cdrom/info
CD-ROM information, Id: cdrom.c 3.20 2003/12/17

drive name:		sr0
drive speed:		24
drive # of slots:	1
Can close tray:		1
Can open tray:		1
Can lock tray:		1
Can change speed:	1
Can select disk:	0
Can read multisession:	1
Can read MCN:		1
Reports media changed:	1
Can play audio:		1
Can write CD-R:		1
Can write CD-RW:	1
Can read DVD:		1
Can write DVD-R:	1
Can write DVD-RAM:	1
Can read MRW:		0
Can write MRW:		0
Can write RAM:		1

Running sudo modprobe sg allows MakeMKV to work as intended.

Lorien added a subscriber: Lorien.Apr 26 2018, 11:55 AM
Lorien added a comment.EditedApr 26 2018, 12:17 PM

Same issue here, think it started after the latest MakeMKV update 9/2-2018, cause it has worked fine not to many months back.

sudo modprobe sg also works for me.

dmesg | egrep -i --color 'cdrom|dvd|cd/rw|writer'
[ 1.790913] usb 4-2: Product: External Blu-ray Writer
[ 5.930048] sr 4:0:0:0: [sr0] scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
[ 5.930053] cdrom: Uniform CD-ROM driver Revision: 3.20

more /proc/sys/dev/cdrom/info
CD-ROM information, Id: cdrom.c 3.20 2003/12/17

drive name: sr0
drive speed: 48
drive # of slots: 1
Can close tray: 1
Can open tray: 1
Can lock tray: 1
Can change speed: 1
Can select disk: 0
Can read multisession: 1
Can read MCN: 1
Reports media changed: 1
Can play audio: 1
Can write CD-R: 1
Can write CD-RW: 1
Can read DVD: 1
Can write DVD-R: 1
Can write DVD-RAM: 1
Can read MRW: 1
Can write MRW: 1
Can write RAM: 1

Budgie 3.999
Kernel 4.15.17-65.current

kyrios123 added a subscriber: kyrios123.EditedApr 26 2018, 12:45 PM

You're right, this should be added to the package.

The quick & dirty workaround you can use for now to load the module automatically is :
echo sg | sudo tee /etc/modules-load.d/sg.conf

Thank you for the workaround Kyrios, the drive shows up after reboot now.

One thing though...

sudo echo sg > /etc/modules-load.d/sg.conf

resulted in "bash: /etc/modules-load.d/sg.conf: Permission denied", so i did sudo nano /etc/modules-load.d/sg.conf , put sg in the file saved and rebooted.

@Lorien yeah sorry I always forget that redirection doesn't work with sudo. I updated my previous comment with a command that should work in case someone else needs it.

joebonrichie closed this task as Invalid.Aug 14 2018, 5:37 PM
joebonrichie added a subscriber: joebonrichie.

MakeMKV has now been deprecated from the repo.

MakeMKV has now been deprecated from the repo.

Where exactly is this documented? I am not seeing anything about MakeMKV being deprecated from the repo.

In fact, upon searching for anything related to deprecating MakeMKV, your comment is the only one that comes up.

I should very much hope that MakeMKV isn't getting deprecated.

There's nothing on MakeMKV's website stating that Linux support is being dropped (unless I've missed it).

I realize that a snap is in the works for it but that's not ready yet.

JoshStrobl added a subscriber: JoshStrobl.EditedAug 15 2018, 10:41 PM

I deprecated it because it was blocking ffmpeg 4 stack upgrade and wouldn't function properly against it, it's practically limping along in development. It's not being re-introduced into the repo.

I deprecated it because it was blocking ffmpeg 4 stack upgrade and wouldn't function properly against it, it's practically limping along in development. It's not being re-introduced into the repo.

"not being re-introduced into the repo"... Like ever? That's an application that a lot of people use. If you're relying on the snap to get created, that's likely a bad move as there's no ETIC for it. Removing -good-fully-featured- applications (like MakeMKV) from the repo isn't providing users with a better experience. It's exactly the opposite of that.

IF you still intend to remove MakeMKV from the repo and never add it again, what application do you suggest that is equal to it's performance and capabilities?

grim85 added a subscriber: grim85.Oct 29 2018, 10:42 PM

Interesting that makemkv has been "removed" blaming ffmpeg 4 as the reasoning, when it continues to function correctly for Fedora from the negativo17 repo and for Arch from the AUR, with the later even listing how they got it to build. As a user wanting to run Solus for a media pc, makemkv is the only reliable solution for decrypting bdplus (the current videolan open library results in artifacts in the video stream, if it manages to decrypt at all).

Is it not possible to put it back in the unstable repo? Or perhaps put a caveat in big text on its listing that as a packager you are unhappy with its functionality

We also removed it because their licensing is cumbersome. Having something stop working between syncs because a license expires is not OK.

We also removed it because their licensing is cumbersome. Having something stop working between syncs because a license expires is not OK.

So for those who own a license, what is the solution going forward?

I'm not a user on neither of the two, but can't you use Handbrake in replacement of MakeMKV?

I'm not a user on neither of the two, but can't you use Handbrake in replacement of MakeMKV?

makemkv is not just a video encoding tool, it is a decryption library that can replace libaacs and libbdplus directly, thus making it available for direct playback of blurays on the system via VLC or Kodi, without having to maintain KEYDB files that very quickly get out of date. It also the only reliable bdplus decryption method. Losing this functionality from Solus is a real pain for those wanting to use it for BD playback

We also removed it because their licensing is cumbersome. Having something stop working between syncs because a license expires is not OK.

So for those who own a license, what is the solution going forward?

Made a seperate Solus 3 installation on an old usb SSD, and installed MakeMKV before it was removed, will not update that installation and only use it when i need to use MakeMKV (i do not need the BD playback you mention). Is this optimal, no, as you i bought a license for the software this year, but i trust that the devs have their reasons for doing this.

So i guess some kind of seperate installation or maybe a live usb, with a distribution that support MakeMKV is the only option...

grim85 added a comment.EditedOct 30 2018, 7:58 AM

So i guess some kind of seperate installation or maybe a live usb, with a distribution that support MakeMKV is the only option...

Went Solus for its purely rolling nature (previously Fedora, but the 6 monthly in place upgrades became impractical) - if makemkv can't/won't be reinstated, I will have to move over to Manjaro or an Arch Derivative. The more curated nature of Solus was what I wanted, but not if they are going to deprecate functionality that I need

kz6fittycent added a comment.EditedNov 25 2018, 9:27 PM

We also removed it because their licensing is cumbersome. Having something stop working between syncs because a license expires is not OK.

I'm not sure what you're referring to as far as an expiring license. My MakeMKV license has no expiration.

I've not had any issue with my license between syncs.

Even if you think it's "cumbersome", maybe run a poll or ask if others feel the same way. I doubt you're gonna find a ton of people who are willing to get rid of MakeMKV because of that reason. There aren't any replacements that can do what this package does.

Please reconsider your position for MakeMKV and add it back to the repo.

I'm not sure what you're referring to as far as an expiring license. My MakeMKV license has no expiration.

Unlike what MakeMKV says on its web site, you can't use all functionalities for free during 30-days trial period. The application is shipped with a demo license that expires on a given date. When the license is expired either you purchase a new license or you install a newer version of MakeMKV.

This means that if you install the application today and the license expires tomorrow, after a few hours the application will stop working and if you install it tomorrow it won't work at all. This is not a 30-day trial and for the user experience, this terrible IMO.

And when this happen, either you have to purchase a license or... as a user you're stuck and there is nothing you can do apart from waiting.. and here comes the 2nd issue: it is not normal that upstream dictates when the application must be updated. Solus has its own publication rules. If Solus can't insure that an application in its repository works fine, then the application shouldn't be offered in the repository !

Harvey added a subscriber: Harvey.Nov 26 2018, 1:29 AM

Unlike what MakeMKV says on its web site, you can't use all functionalities for free during 30-days trial period. The application is shipped with a demo license that expires on a given date. When the license is expired either you purchase a new license or you install a newer version of MakeMKV.
This means that if you install the application today and the license expires tomorrow, after a few hours the application will stop working and if you install it tomorrow it won't work at all. This is not a 30-day trial and for the user experience, this terrible IMO.

Just a slight correction no reinstall is needed, the user can use the free license for as long as the program is in beta. The user just needs to update the new license key provided free from their forum:
https://www.makemkv.com/forum/viewtopic.php?f=5&t=1053

I understand this may not change Solus's stance, that's fine, I don't really care I don't use the program anymore. But I thought some clarification was needed.

I'm not sure what you're referring to as far as an expiring license. My MakeMKV license has no expiration.

Unlike what MakeMKV says on its web site, you can't use all functionalities for free during 30-days trial period. The application is shipped with a demo license that expires on a given date. When the license is expired either you purchase a new license or you install a newer version of MakeMKV.
This means that if you install the application today and the license expires tomorrow, after a few hours the application will stop working and if you install it tomorrow it won't work at all. This is not a 30-day trial and for the user experience, this terrible IMO.
And when this happen, either you have to purchase a license or... as a user you're stuck and there is nothing you can do apart from waiting.. and here comes the 2nd issue: it is not normal that upstream dictates when the application must be updated. Solus has its own publication rules. If Solus can't insure that an application in its repository works fine, then the application shouldn't be offered in the repository !

I'm not sure you've considered those who've PAID for a license...

Please reconsider adding MakeMKV back to the official repo.

DataDrake changed the task status from Invalid to Locked.Nov 26 2018, 6:51 PM

Now you are just being rude. It wasn't @kyrios123 decision to drop it from the repo. It was mine and @JoshStrobl's. Whether or not you have paid for the software had no bearing on the decision. It blocked the ffmpeg 3 update and I won't have one-off pieces of software holding us back from updating core software for weeks at a time. Combine that with the number of complaints that we received from non-paying users about the license expiring between syncs and it was only a matter of time before we kicked it out.

I'm locking this task as it is clear that nothing more productive will come from it being open.

This task has been locked.