Page MenuHomeSolus

Frequency of ISO Snapshots
Closed, ResolvedPublic

Description

Could we possibly have more frequent snapshots for the downloadable ISO's on the website?

I've had a handful of friends that have run into issues because they've installed Nvidia-proprietary drivers using DoFlicky before running sudo eopkg up. This has lead to them having the latest video drivers, but a really old base system. This usually causes them to boot into a TTY as Xorg fails to properly start and gives them a pretty bad impression of Solus.

It's an easy fix, as they can eopkg up post-driver-install and it would fix everything, but it just looks bad from a first-user's perspective.

Could we please have snapshots that get automatically updated every month or so? It would also save a lot of time as users don't have 400+ packages to update from a new install, too.

How to reproduce?

  1. Fresh install of Solus Budgie.
  2. Update Nvidia-proprietary drivers via DoFlicky.
  3. Reboot and enjoy the sweet new GPU-accelerated command line interface.

An automated method of generating snapshots periodically would be ideal.

Related Objects

Event Timeline

Snuggle created this task.Mar 12 2018, 1:30 AM
Snuggle renamed this task from Increase Frequency of 'ISO Snapshots to Frequency of ISO Snapshots.Mar 12 2018, 1:30 AM
Snuggle updated the task description. (Show Details)

We don't do snapshots. We do releases. I also understand its frustrating its been a while but we will try to keep our releases more frequent after Solus 4. We didn't anticipate it taking so long but so much of the core architecture has changed

Snuggle closed this task as Resolved.EditedMar 15 2018, 4:12 PM
Snuggle claimed this task.

Okay, @ikey. It’s primarily the fact that people updating their drivers before running sudo eopkg up can boot into a TTY since X fails to start and people tend to panic when “things have broken”.

Just something to keep in mind for the future! Thank you and I hope I didn’t sound abrasive. ?


Self-closing this as this is something that will be fixed in the next release and hopefully won’t become an issue again.

Yeah its an ugly situation we're in and we've had to repeatedly tell people do NOT use doflicky before a full update as you know yourself with the kernel thing. Killing DoFlicky will help there. Cheers for bring it up though lad you're bang on.

Snuggle updated the task description. (Show Details)Jun 13 2018, 10:16 AM
Snuggle added subscribers: nvcnvn, racerdot.