Page MenuHomeSolus

opencpn
Closed, InvalidPublic

Description

Title: OpenCPN chartplotter navigation

Homepage https://opencpn.org
There are few, if no alternatives. This is a popular chartplotting program for yachts. There are versions for OpenSUSE, Ubuntu, Fedora, etc.
It is open source link is https://github.com/OpenCPN/OpenCPN/tree/v4.8.0
Latest version (master) is 4.8.2 dated 2/28/2018
Thank you

Event Timeline

ArjenR added a subscriber: ArjenR.Apr 23 2018, 9:12 PM

There is a snap available (edge version). https://github.com/msis/OpenCPN-snap
But it uses some font that I do not have. It also reports some missing modules:
Gtk-Message: Failed to load module "gail"
Gtk-Message: Failed to load module "atk-bridge"
Gtk-Message: Failed to load module "canberra-gtk-module"

YMMV

DataDrake triaged this task as Wishlist priority.Jul 22 2018, 12:54 PM
DataDrake moved this task from Backlog to Accepted For Inclusion on the Package Requests board.
JoshStrobl closed this task as Wontfix.Aug 16 2018, 8:13 PM
JoshStrobl claimed this task.
JoshStrobl added a subscriber: JoshStrobl.

It's been a month since this has been accepted and marked for needs maintainer. Given nobody has stepped up to provide an accepted patch, marking as wontfix. Feel free to re-open when a patch has been submitted via the appropriate process.

Unknown Object (User) reopened this task as Open.Oct 10 2018, 8:12 PM
Unknown Object (User) added a subscriber: Unknown Object (User).

Hello all,

I'm a new user of Solus Project and new too in compiling package. I want to try to make an OpenCPN package but i think i need a little help to manage it. Is some one can help me in the first step, please ?

Unknown Object (User) added a comment.Oct 11 2018, 7:44 PM

@Girtablulu Thank you for the link.
I already follow these infos and i don't understand the result you can see above.

make build
make[1] : on entre dans le répertoire « /home/jmi/Building/OpenCPN-4.8.4 »
sudo solbuild build pspec.xml -p unstable-x86_64; 
Mot de passe : 
Failed to load package: open pspec.xml: no such file or directory
make[1] : on quitte le répertoire « /home/jmi/Building/OpenCPN-4.8.4 »
make abireport
make[1] : on entre dans le répertoire « /home/jmi/Building/OpenCPN-4.8.4 »
abireport -p abi_ -D `dirname pspec.xml` scan-packages `dirname pspec.xml`
Error locating packages: No packages in directory .

make[1]: *** [../Makefile.common:15: abireport] Error 1
make[1] : on quitte le répertoire « /home/jmi/Building/OpenCPN-4.8.4 »
make: *** [../Makefile.common:12: complete] Error 2

Can you tell me the right way to make the "pspec.xml" file that is missing ?

Unknown Object (User) added a comment.Oct 12 2018, 9:10 PM

Today I try this and it failed as you see.

jmi@rosetta ~/Building $ sudo tar -cf ./OpenCPN-4.8.4.tar ./OpenCPN-4.8.4
jmi@rosetta ~/Building $ sudo ./common/Scripts/yauto.py file:./OpenCPN-4.8.4.tarVerifying file:./OpenCPN-4.8.4.tar
OpenCPN-4.8.4.tar

Completed verification
Package: opencpn
Version: 4.8
tar: Ceci ne ressemble pas à une archive de type « tar »
tar: Arrêt avec code d'échec à cause des erreurs précédentes
unknown

Do somebody know were is the problem ? I just put /data /docs /include /plugins /po /src and the README file in the tar archive.

Unknown Object (User) added a comment.Oct 13 2018, 1:38 PM

@JoshStrobl Hello Josh,
I'm sorry for my stupid questions but i'm a beginner in compiling programs. Can you help me, please?
is it my job to create the file "Makefile" to put in the package or a tool exist to create it from the sources files ?
The script yauto.py gives me an empty package.yml is it normal ?
If i learn how to compile well i cant be maintainer for the OpenCPN package if it can help the SolusProject.
Regards.

yauto is expecting a URL to the tarball, not a local file.

Unknown Object (User) added a comment.Oct 16 2018, 5:53 AM

Hello @DataDrake

That’s what i wrote an url with file: instruction to link to a local file. Ils it a wrong way to use yauto?

Regards

JagdCake added a subscriber: JagdCake.EditedOct 16 2018, 6:55 AM

You need to pass this URL to yauto: https://github.com/OpenCPN/OpenCPN/archive/v4.8.4.tar.gz.

Tarballs can be found here: https://github.com/OpenCPN/OpenCPN/releases

JoshStrobl removed JoshStrobl as the assignee of this task.Oct 16 2018, 11:57 PM
Unknown Object (User) added a comment.Oct 17 2018, 6:15 AM

@JagdCake thanks to you. I have now a yml file but i bref to learn how to use it. Can you explain me thé way to mâle and compile an application please.

Regards

Regards

JoshStrobl closed this task as Invalid.Oct 17 2018, 6:38 AM

@JMD We have documentation, I suggest reading it. https://getsol.us/articles/packaging/

As stated in my closing of the task: Feel free to re-open when a patch has been submitted via the appropriate process.

Unknown Object (User) added a comment.Oct 24 2018, 5:32 PM

@JochStrobl , Ok Josh, thank you for your very nice welcome.

I think I am part of the way there, but I am running into an issue, and I am not quite sure I understand the root cause. I have compiled software before, but I am a network engineer, not a software developer, so some of this slips through my fingers.

In my package.yaml, I have the following dependancies:

  • libglu-devel
  • wxwidgets-devel
  • curl-devel
  • libcairo-devel

However, my make fails as follows:

Some or all of the gtk libraries were not found. (missing: GTK2_GTK_LIBRARY GTK2_GTK_INCLUDE_DIR GTK2_GDK_INCLUDE_DIR GTK2_GDK_LIBRARY) 
Checking for module 'gtk+-3.0'
No package 'gtk+-3.0' found
Could NOT find GTK3 (missing: GTK3_INCLUDE_DIRS GTK3_LIBRARIES) 
Building against GTK3...
Could NOT find wxWidgets (missing: wxWidgets_LIBRARIES wxWidgets_INCLUDE_DIRS) 
Could not find wxWidgets webview add-on
CMake Error at /usr/share/cmake-3.17/Modules/FindPackageHandleStandardArgs.cmake:164 (message):
Could NOT find wxWidgets (missing: wxWidgets_LIBRARIES
wxWidgets_INCLUDE_DIRS)
Call Stack (most recent call first):
/usr/share/cmake-3.17/Modules/FindPackageHandleStandardArgs.cmake:445 (_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-3.17/Modules/FindwxWidgets.cmake:1008 (find_package_handle_standard_args)
CMakeLists.txt:1063 (FIND_PACKAGE)

Configuring incomplete, errors occurred!

I am sure I am missing something simple here, and I would very much appreciate a pointer.

The issue is that the OpenCPN cmake system is a bit odd. It detects WxWebview as unavailable, but still sets the build paramater. This paramater seems to be exposed to the command line as well as other variables, but ignores them all.

%cmake -DCMAKE_INSTALL_PREFIX=/usr -DOCPN_USE_WEBVIEW=OFF

in the solbuild environment does not work.

The upcoming release changes things around and I could create a patch that harcodes it to OFF in CMakeLists.txt.
It does build and run!

BTW: WxWebview is only used for the About window....

If I have time these coming days I will readup on the package proces (it has been a while) and submit mine for review.