Page MenuHomeSolus

Offline mounted NFS share causes login failure with message "System is booting up. See pam_nologin(8)", and the password is rejected.
Open, Needs More InfoPublic

Description

I have FreeNAS running on a vmware server. The server went down tonight and my mounted NFS share in Solus went down with it

During early troubleshooting, I rebooted my primary desktop (Solus). When I booted back up, I was greeted with an error message on the login screen: "System is booting up. See pam_nologin(8)". https://imgur.com/a/Bl8kh

Every attempt to enter my password would fail, claiming my password was wrong, which it wasn't. After about 30 seconds of waiting (presumably when it timed out trying to access my mounted share), the screen turned black like it had just rebooted, and then the login screen would reappear without any errors, and I was able to log in fine.

This happened every time I rebooted Solus while my NAS was offline.. so I think it should be easily reproducible.

Not a major issue, but it shouldn't happen

Event Timeline

Beer created this task.Feb 25 2018, 7:35 AM
Beer updated the task description. (Show Details)Feb 25 2018, 7:36 AM
Beer updated the task description. (Show Details)
DataDrake triaged this task as Needs More Info priority.Oct 16 2018, 7:51 PM
DataDrake added a subscriber: DataDrake.

Is this mount happening from /etc/fstab?

JoshStrobl closed this task as Resolved.Mar 1 2019, 9:11 PM
JoshStrobl claimed this task.
JoshStrobl added a subscriber: JoshStrobl.

Closing due to lack of response.

Beer added a comment.EditedMar 1 2019, 9:19 PM

Sorry, I must have missed a notification for his last reply. Yeah, it has always been in fstab and I always reuse the same configuration:

192.168.1.201:/mnt/thunder/media_nfs    /media/nas      nfs     defaults        0       0

If I remember this weekend, I'll test a reboot while my NAS is down and see if the issue still exists.

JoshStrobl reopened this task as Open.Mar 1 2019, 9:49 PM
JoshStrobl removed JoshStrobl as the assignee of this task.