Page MenuHomeSolus

Scaling issues with Nvidia drivers
Closed, ResolvedPublic

Description

After installing the latest Nvidia drivers (390.25-226) on my Optimus laptop running Solus Plasma from the latest preview ISO, I'm experiencing a number of graphical "glitches" - UI element spacing and text are all shrunk down and animations like NetworkManager's spinner when connecting to a network are sped up - NM's spinner looks more like a solid circle than a loading animation, it goes so fast.

The issue gets fixed when the Nvidia drivers are removed, so I know it is an issue related to the drivers/LDM, but it is also a Plasma issue because this didn't happen on Budgie. Last tested after today's (2/26/2018) updates.

Screenshots are attached.

Event Timeline

Shadow53 updated the task description. (Show Details)Feb 27 2018, 1:16 AM
Shadow53 updated the task description. (Show Details)Feb 27 2018, 1:19 AM
domacs added a subscriber: domacs.EditedFeb 27 2018, 2:23 PM

I can confirm the small text, but i prefer the smaller text over the original one xD

Well the question is then, what settings are accessible (and therefore likely set) in the nvidia settings tool.

KDE with proprietary Nvidia drivers tends to set too low DPI so font appear too small.

animations like NetworkManager's spinner when connecting to a network are sped up - NM's spinner looks more like a solid circle than a loading animation, it goes so fast.

Reminds old games running too fast on modern OS/HW , vertical sync could help here.

KDE with proprietary Nvidia drivers tends to set too low DPI so font appear too small.

Can confirm this after looking at nvidia-settings. DPI changes from 96 to 75 after installing Nvidia drivers.
Adding a file /etc/sddm.conf.d/20_dpi_fix.conf with the following contents fixed the DPI problems:

[X11]
ServerArguments=-nolisten tcp -dpi 96

Oddly enough, setting DPI in the Plasma Settings application didn't help anything.

Reminds old games running too fast on modern OS/HW , vertical sync could help here.

I tried forcing vsync by changing "tearing prevention (vsync)" in the KWin compositor settings but none of the options changed anything. I'm not sure how else I would go about doing so - there isn't an option in nvidia-settings for it. Not even setting animations to the slowest possible made a difference.

I recall somewhere about DPI stuff being different with lightdm and sddm, but haven't looked at that yet.

Oddly enough, setting DPI in the Plasma Settings application didn't help anything.

Can you try removing the sddm workaround and installing the xrdb package. Looking at the code, we need that for it to work (and confirmed fonts changed when DPI was set to 120).

Can you try removing the sddm workaround and installing the xrdb package. Looking at the code, we need that for it to work (and confirmed fonts changed when DPI was set to 120).

Installed the latest updates (which brought in xrdb) and rebooted. This worked for getting DPI settings to change based on the option in System Settings.

Removing the sddm workaround still causes DPI to be incorrect on the login screen itself and in user sessions when DPI is not being forced to a certain value. Is it possible to implement something to detect what the DPI should be and force that through SDDM when Nvidia drivers are installed?

5.13 maybe will fix this issue, it seems that there was a bug in kde that force dpi in system settings did now work, ist will be fixed in 5.13.

5.13 maybe will fix this issue, it seems that there was a bug in kde that force dpi in system settings did now work, ist will be fixed in 5.13.

Does this come with a reference?

shure, sorry
https://bugs.kde.org/show_bug.cgi?id=394180
im not 100% shure that this will work with nvidia, but i think it will

DataDrake triaged this task as Normal priority.Oct 16 2018, 8:46 PM
Girtablulu closed this task as Resolved.Mar 14 2019, 1:47 PM
Girtablulu claimed this task.
Girtablulu added a subscriber: Girtablulu.

This should be fixed for a while, since stable is on 5.14.5

Actually, I still face this issue.

KDE version: 5.17.4
NVIDIA driver version: 440.44

After installation, I had to change the font size of all elements of the system because they were too small. I tried to change also the sddm settings (System Settings -> Startup and Shutdown -> Login Screen -> Advanced -> Settings Synchronization: Sync), but nothing changed in the login screen (at least, not when the system starts... if I lock/suspend the session, when I have to insert my password to unlock fonts are ok).