Page MenuHomeSolus

Miniconda Package Request
Closed, DuplicatePublic

Description

Name:
Miniconda (The package is called miniconda but the library in bash is called conda)

Homepage:
https://conda.io/miniconda.html

Why should this be included:
It's an alternative of pip that's strongly preferred by data scientists and some python developers due to dramatically improved ease of use

Open source:
Yes

How many users:
Most to all of the the data scientists I've worked with and some of the Python developers. I don't know how many of those use Solus right now, but they're a big part of Linux users

Link:
https://github.com/conda/conda
https://docs.anaconda.com/anaconda/packages/pkg-docs

Additional Notes:
Having both the current python3 version (at this time python3 3.6) and the Python 2.7 version is important due to the version split in python.

Also note that this isn't a duplicate of pip, and that pip isn't a duplicate of it. Pips offers better software support, conda provides ease of use and native virtualization. There's no clear winner for the general case, but there are major winners for specific cases, hence justifying the inclusion (and industry usage) of both.

DataDrake closed this task as a duplicate of T5226: conda.Jul 22 2018, 1:56 PM