Page MenuHomeSolus

TensorFlow - Computation using data flow graphs for scalable machine learning
Closed, ResolvedPublic

Description

Related Objects

Mentioned In
T6740: bazel

Event Timeline

rjurga created this task.Feb 4 2018, 1:41 PM

@rjurga This will be CPU only, is that okay?

If/when cuda gets included in Solus, it can then be included in Tensorflow too. In the meantime I don't see any other way, it's CPU only or just wait for cuda. The only downside to include it with CPU only is that I'd expect uninformed users to be tempted to report issues about it.

Personally I'd still use it even without GPU support. =)

DataDrake triaged this task as Normal priority.Mar 15 2018, 8:33 PM
DataDrake moved this task from Backlog to Accepted For Inclusion on the Package Requests board.
saitam added a subscriber: saitam.EditedSep 22 2018, 8:22 PM

Everybody who has an AMD gpu has now a possibility for machine learning under Solus. I just got an gpu accelerated MNIST example to run :) With kernel 4.18 just type the command

echo 'SUBSYSTEM=="kfd", KERNEL=="kfd", TAG+="uaccess", GROUP="video"' | sudo tee /etc/udev/rules.d/70-kfd.rules

(see ROCm for details). After that just pull the rocm tensorflow docker image (rocm-tensorflow) and thats it. Happy machine learning ...

Update: Works without command line. Docker is enough.

DataDrake reopened this task as Open.May 17 2019, 2:55 PM

So, When I pushed this to the build server it got stuck during the last stage of compressing the archives. I'm not sure what the cause is yet.

So, When I pushed this to the build server it got stuck during the last stage of compressing the archives. I'm not sure what the cause is yet.

@DataDrake The build of tensorflow takes massive memory and storage space and that causes problem for me when building it on my desktop. I had to limit the ram usage by adding "--ram_utilization_factor=10" to limit ram usage. Could this be a problem for our build server? If not, could we try building it again on the server and see whether it is reproducible?

I will probably try again. it got stuck after the build had finished.

DataDrake closed this task as Resolved.May 21 2019, 4:21 AM

I just wasn't patient enough.