Page MenuHomeSolus

Unable to change screen brightness on MacBook Pro (AMD Radeon R9)
Closed, InvalidPublic

Description

Solus doesn't allow to change the screen brightness on a MacBook Pro (AMD Radeon R9). Not even by changing the sys/class/backlight/... files.

Might be caused by this driver, which is for Nvidia:

filename:       /lib/modules/4.14.14-47.current/kernel/drivers/video/backlight/apple_bl.ko
alias:          mbp_nvidia_bl
license:        GPL
description:    Apple Backlight Driver
author:         Matthew Garrett <mjg@redhat.com>
alias:          acpi*:APP0002:*
depends:        
intree:         Y
name:           apple_bl
vermagic:       4.14.14-47.current SMP mod_unload modversions 
parm: debug:Set to one to enable debugging messages. (int)

Relevant information:
/sys/class/dmi/id/modalias: dmi:bvnAppleInc.:bvrMBP114.88Z.0172.B25.1706181512:bd06/18/2017:svnAppleInc.:pnMacBookPro11,5:pvr1.0:rvnAppleInc.:rnMac-06F11F11946D27C5:rvrMacBookPro11,5:cvnAppleInc.:ct9:cvrMac-06F11F11946D27C5:

/sys/class/backlight/acpi_video0/device/modalias and /sys/class/backlight/acpi_video0/device/modalias: pci:v00001002d00006821sv0000106Bsd00000149bc03sc00i00

Workaround, put: blacklist apple_gmux in a file under modprobe.d, e.g: /etc/modprobe.d/noapplebl.conf .

ikey is already aware of this.

Event Timeline

Siilwyn created this task.Jan 23 2018, 12:37 PM

@JoshStrobl this is not the same issue as T5008. As it is about a MacBook with a Nvidia GPU and in that case the brightness is adjustable. In this case it is not adjustable in any way and is caused by a Nvidia driver loading in on a AMD GPU.

@ikey @JoshStrobl this is not the same issue, could you re-open this issue?

JoshStrobl reopened this task as Open.Feb 11 2018, 4:35 PM
JoshStrobl edited projects, added Hardware; removed Lacks Project.
Siilwyn closed this task as Resolved.Oct 7 2018, 4:09 PM
Siilwyn claimed this task.

This seems to be fixed now at Linux 4.18.11-93.current, I have no idea why: modinfo apple_bl still returns the same Nvidia driver while I still have an AMD card...

Siilwyn reopened this task as Open.Jan 14 2019, 8:20 AM

Sorry but that was a false positive... This issue is partly fixed, I can change the brightness but it always returns to 100% on reboot and the laptop goes on while closed randomly burning to battery quickly. The posted workaround still solves all of this.

JoshStrobl closed this task as Invalid.Jan 14 2019, 9:21 AM

I can change the brightness but it always returns to 100% on reboot

If you can change the brightness than I fail to see how this is a valid issue. You reported you couldn't change the brightness, you can. Displays being at 100% brightness on start is fairly common, regardless of whether or not it's a Macbook.

Suspend is a completely different issue and would warrant a separate task if one does not already exist.

Siilwyn rescinded a token.Jan 16 2019, 6:22 PM