Page MenuHomeSolus

Timeshift backup utility
Closed, DuplicatePublic

Description

Description from Timeshift website.
TimeShift for Linux is an application that provides functionality similar to the System Restore feature in Windows and the Time Machine tool in Mac OS. TimeShift protects your system by taking incremental snapshots of the file system at regular intervals. These snapshots can be restored at a later date to undo all changes to the system.

Name of the software
Timeshift
Project/product Homepage
http://www.teejeetech.in/p/timeshift.html
https://launchpad.net/timeshift
Is it open source?
Yes.
Source Tarball
http://dl.dropbox.com/u/67740416/linux/timeshift-latest-amd64.run?dl=1

Event Timeline

JoshStrobl closed this task as a duplicate of T220: Timeshift.Dec 30 2017, 1:18 AM