Page MenuHomeSolus

docker client version "unknown-version"
Closed, ResolvedPublic

Description

Hey all,

Trying to manually install nvidia-docker a la T3641, but there appears to be a parsing error with the current docker client's version output.

Whereas an alphanumeric string is expected, the client version outputs "unknown-version".

$ sudo nvidia-docker
nvidia-docker | 2017/12/21 11:18:41 Error: expected integer
sudo docker version
Password: 
Client:
Version:      unknown-version
 API version:  1.34
 Go version:   go1.9.2
 Git commit:   1caf76ce6b
 Built:        Sun Nov 26 16:16:03 2017
 OS/Arch:      linux/amd64

Server:
 Version:      17.11.0-ce
 API version:  1.34 (minimum version 1.12)
 Go version:   go1.9.2
 Git commit:   7cbbc92838236e442de83d7ae6b3d74dd981b586
 Built:        Sun Nov 26 16:15:47 2017
 OS/Arch:      linux/amd64
 Experimental: false

EDIT: using prebuilt binaries as workaround for now
https://docs.docker.com/v1.11/engine/installation/binaries/

Event Timeline

12amnewday updated the task description. (Show Details)Dec 22 2017, 10:23 AM
JoshStrobl triaged this task as Normal priority.Jan 27 2018, 6:05 PM
JoshStrobl edited projects, added Software; removed Lacks Project.
JoshStrobl moved this task from Backlog to Package Fixes on the Software board.
jd added a subscriber: jd.EditedFeb 8 2018, 7:52 PM

Hi,

Same behavior with a fresh docker install using eopkg, which is expected. Installed version is 17.11.0.

tribals added a subscriber: tribals.