Page MenuHomeSolus

Thunderbird Lightning is always in default language (English)
Closed, ResolvedPublic

Description

On a fresh Solus installation using german language/locale the Thunderbird calendar is still in English. Removing the addon, then searching for "Lightning" in the add-ons menu and installing it apparently installs a localized variant with UI elements in correct language (in this case German).

Event Timeline

Daniel created this task.Dec 20 2017, 12:25 PM
JoshStrobl edited projects, added Software; removed Lacks Project.Jan 27 2018, 6:09 PM
taaem added a subscriber: taaem.Feb 13 2018, 5:05 PM
DataDrake closed this task as Invalid.Mar 15 2018, 8:20 PM
DataDrake edited projects, added Upstream Issue; removed Software.
DataDrake added a subscriber: DataDrake.

We do not control how thunderbird builds its default addons. I'm sorry for the inconvenience, but there is nothing we can do to fix this at compile time.

Well, yes, upstream issues. But Solus switched to TB60 and since then, the previously correct localization is broken again.
The workaround to uninstall and reinstall the Lightning XPI to correct the announg mixture of language (TB is german, L is english) doesn't work since there's no XPI 6.2 for TB60 to download.
Please investigate the cause of this glitch, this should affect ALL non-english users!

BTW: The (per default activated) Website that is loaded instead of the first message content says that the current TB60 be "Daily", not "Release" - is that so?

This problem and it's workaround is mentioned in the release notes.

https://www.thunderbird.net/en-US/thunderbird/60.0/releasenotes/

As DataDrake said, there is nothing we can do at our level, this will be addressed by upstream.