Page MenuHomeSolus

Resume from hibernate results in black screen
Closed, ResolvedPublic

Description

Operating System: Solus, stable (updated at the time of writing, 17.12.17), kernel 4.14.6-40.current
Budgie version: budgie-desktop 10.4
Hardware: ThinkPad X230T, Intel graphics, swap partition matches RAM and resume UUID is properly set as a kernel parameter

The issue encountered
When the laptop resumes from hibernate, the system boots up but the screen stays black. However, the system is responsive: When the terminal was the last open and focused application, I can just type my password, press enter and type "reboot" in the terminal upon which the system reboots as it should.
This was a so far a common problem for me which could be easily solved by following https://wiki.archlinux.org/index.php/Kernel_mode_setting#Early_KMS_start . However, adding the file "10-intel.conf" with "add_drivers+="i915"" to /etc/dracut.conf.d and rebuilding with sudo dracut -f did not solve the issue.
What works surprisingly is using nomodeset as a kernel parameter. The VESA driver is used then and hibernation works.
Anything else I could try?

Update

I found a hint in the journalctl log:

atomic remove_fb failed with -22

Which lead me to this bug report: https://bugs.freedesktop.org/show_bug.cgi?id=101865
However, in my case hibernation works when I set "xset -dpms" manually.
Hibernation was working before on Solus on the same machine, however I reinstalled and switched from GNOME to Budgie. I guess this issue could be related to a kernel regression (indicated in the last message of the bug report) or maybe to the screensave/lock in lightdm?

Event Timeline

DonHugo created this task.Dec 17 2017, 5:42 PM
DonHugo updated the task description. (Show Details)Dec 17 2017, 11:02 PM
Edgar21r triaged this task as Normal priority.Dec 18 2017, 1:08 PM
JoshStrobl raised the priority of this task from Normal to Needs Triage.Dec 18 2017, 1:34 PM
JoshStrobl added a subscriber: JoshStrobl.

Cleaning up the mess, don't mind me.

JoshStrobl edited projects, added Hardware; removed Lacks Project.Jan 27 2018, 6:13 PM

I have the same issue, hibernation results in a black screen when resuming. I have set the resume kernel parameter to my swap partition's UUID using these instructions.

I can confirm that the xset -dpms seems to work!

DataDrake triaged this task as Needs More Info priority.Aug 26 2018, 7:24 PM
DataDrake added a subscriber: DataDrake.

Is this still an issue?

DataDrake closed this task as Invalid.Oct 16 2018, 6:41 PM

Closing due to lack of response in over 30 days.

Still an issue in Solus 3.9999 budgie 10.5 on an HP Probook laptop with Intel and AMD graphics.

I actually created an issue on the budgie github this afternoon. Apparently executing xset -dpms before locking the screen does help with the screen unlocking, the screen doesn't power off, the wallpaper is displayed with the status bar at the top and clicking/moving the mouse makes the login pop up appear (everything work as intended after this).

In my case suspending still causes the laptop to crash but I'm not sure if I should create another ticket about this.

If it's an issue from the system should I close the issue on the budgie github ?

Tzigamm reopened this task as Open.Jan 16 2019, 9:15 PM

Reopened as discussed with DataDrake on the Solus-Dev channel

Tzigamm closed this task as Resolved.Jan 22 2019, 7:11 PM
Tzigamm claimed this task.

Solved for me, it was actually a xorg problem, a misconfigured GPU, to solve it I deleted the custom intel.conf file I created previously