Page MenuHomeSolus

Windows option missing in boot menu after update
Closed, ResolvedPublic

Description

This is a known issue. This task serves as a reference to a quick and dirty fix for the new users.

After updating and rebooting a computer which is dual-booting Solus and Windows the latter option is missing from the boot menu. You can fix this by running:

sudo update-grub

Event Timeline

meborc created this task.Sep 9 2016, 8:17 AM

I also noticed this issue in various multi-boot setups.

DataDrake closed this task as Resolved.Sep 24 2016, 2:00 PM
DataDrake claimed this task.
DataDrake added a subscriber: DataDrake.

Thanks for reporting back. I'm going to mark this as resolved and hopefully people will search for it and find it before reporting the same problem.

I've noticed this after any update that includes updating the kernel and still exists as an issue that I've had to walk my father through completing over the phone. Are there any plans to fix this in the background so that I (and others) do not have to intervene on every kernel update?

th3_3xpi reopened this task as Open.Oct 19 2016, 4:00 PM
th3_3xpi added a subscriber: th3_3xpi.

Yep, I had this problem also. Every kernel update hide windows boot entry. This bug must be reopened.

ikey claimed this task.Oct 19 2016, 4:10 PM
ikey triaged this task as Unbreak Now! priority.
ikey added a project: Plumbing.

I can confirm this happened to me as well after updating to kernel 4.8.2. The Update-Grub command resolved it, hopefully it doesn't do this for every kernel update :P

When the fix does come in, it will require one last update to reset it. I'm currently freeing up disk space for VM testing so I can test what does and doesn't go boom. It's super annoying, I know, please bear with. I want it fixed

Update to 4.8.4 - same problem :)

melzua added a subscriber: melzua.Oct 30 2016, 6:09 PM
Justin added a subscriber: Justin.Oct 31 2016, 3:03 AM

Update to 4.8.4 - same problem :)

Yes because a fix hasn't been implemented yet.

STiAT added a subscriber: STiAT.Feb 19 2017, 10:03 PM
STiAT added a comment.Mar 7 2017, 12:35 AM

As a note, this is not just Solus specific, Manjaro / Arch have / had this issue until switching to pacman hooks as well, and I've had it on several more distros.

It certainly looks like an os-prober issue under certain circumstances which I don't understand yet. What would help is if I could get debug logs from os-prober during the grub-update of the kernel, but I can't seem to find where os-prober is called during the whole kernel/update-grub process.

What is a bit strange, usually os-prober outputs debug logs to syslog (even when called via update-grub), only when the kernel update is performend not. This means that OS_PROBER_DISABLE_DEBUG must get set somewhere to supress those messages - but I can not find where.

@STiAT there's nothing to work out, read T2145. Manjaro/Arch also update their kernels like us, by removing the existing kernel from disk. Thus, ntfs (and other modules) cannot be loaded, so the disk cannot be mounted, and os-prober cannot .. probe. It's why we need CBM

STiAT added a comment.EditedMar 8 2017, 12:40 AM

@ikey that's actually what I hoped to find since I had a suspicion like that. But I actually could not find evidence for it.

Reason why I got to that conclusion:
If I preload ntfs module, even mount the disks, os-prober during kernel update still didn't find the disks. maybe there is something other flaky going on, but it was evidence that not finding the ntfs module (while already loaded) isn't the issue. That's how I personally interpreted the issue.

I thought - how about reinstalling the current kernel (not a new release).

eopkg rm kernel kernel-modules && eopkg it kernel kernel-modules

Even while having them loaded. Yes, we are limited to hardcoded pathes, but os-prober is run after the install of kernel-modules. Replacing the kernel currently installed, that should not be a pathing issue. Which made me dig closer. Maybe I missed something essential though. I'll trust your expertise though, if it does not work later we can still try to hunt it down.

ikey closed this task as Resolved.Mar 26 2017, 4:53 PM

The first update moving to clr-boot-manager, this problem will persist. However, for all updates after this, (CBM managed) the problem is resolved

I'm still having this problem... 2nd update since moving to CBM

STiAT added a comment.EditedApr 18 2017, 8:18 AM

Nope, still no windows option after this update. Had to re-run update-grub again. Unless I need to configure something special for CBM to work, it's still broken.

Maybe i need to run crm-boot-manager update for it to work on the next update? Then it could be that I destroyed it again after the last update for the next to work ;-).

STiAT reopened this task as Open.Apr 20 2017, 12:29 PM

Reopening. Last update I did run clr-boot-manager update and it found the partition.
Todays kernel update - windows was gone again from the boot entries.

Maybe due to the reason that I've windows on a seperate disk (not the same solus is installed on), but it does not work as I'd expect it.

zJelly added a subscriber: zJelly.Apr 20 2017, 10:27 PM
In T524#59733, @STiAT wrote:

Maybe due to the reason that I've windows on a seperate disk (not the same solus is installed on), but it does not work as I'd expect it.

am having the same issue with this same configuration

I can also confirm that the issue exists.
After todays kernel update windows is gone from grub.
I also have Solus and Windows 10 on separate drives (not sure this is important).
Rebooting Solus after update did not fix the grub.
"sudo update-grub" still fixes the issue.

whatever added a subscriber: whatever.EditedApr 23 2017, 5:56 AM

Another confirmation. Never stopped happening. Confirmed while updating to 4.9.20, 4.9.21, 4.9.22. I don't really mind running 'update-grub' once in a while, but this is clearly a bug that needs resolving.

Edit: I have both Windows 10 and Solus on same partition, if that helps. Also, I have an acer machine with bios (sandybridge).

BTW, when I run sudo update-grub it finds Windows Vista (I have 10). If I reinstall GRUB, it finds Windows 10. But if I run sudo update-grub it finds Vista again. Not sure if it's somehow related.
I have Solus and Windows 10 in same Hard Drive, different partitions.

@iachopolo It's probably part of how it detects the Windows bootloader. I installed Solus in a dual boot on a computer that was running Windows 10 but came with Vista and it detected the bootloader as Windows Vista. I personally doubt it's related to this issue, but others will know better than me.

@whatever on the same partition? That.... can't be right.... You mean drive, right? Not partition? Cause that just sounds.... wrong...

(For the record, I do not have the aforementioned desktop available to see if this is still an issue)

STiAT added a comment.Apr 24 2017, 9:57 PM

@Shadow53 certainly not the case.

  • I have a clean win10 install here at home, detected as Vista (running clr-boot-manager update manually, not recognized at all after kernel updates)
  • I have a clean win7 enterprise install at work, detected as Vista (running clr-boot-manager update manually, not recognized at all after kernel updates).
Justin removed a subscriber: Justin.Apr 25 2017, 11:40 AM

So I'm hopeful that this one will actually fix it: https://git.solus-project.com/packages/kernel-glue/commit/?h=kernel-glue-4-191

Also, the Vista vs 10 issue is kinda not relevant atm, It's just a label issue, and newer versions of os-prober fail to boot it entirely, while
correctly labelling it.

Let's keep this particular bug on the lines of "my Windows disappears"

Please, keep an eye out for the update coming from unstable, and lets track it. The first update it MIGHT disappear, but the second time
it should DEFINITELY NOT... Please check before running "sudo update-grub", as that kinda defeats the purpose entirely. Ta. :)

These updates are now in - please try.

This is fixed for me, thanks! I updated to kernel 4.9.25, and without running sudo update-grub and restarting, I saw the Windows option available. It still shows as Windows Vista, but it has booted fine before, just the wrong name. Nice way to troll us, thinking Windows 7 became Vista haha.

Using Solus Mate, I just noticed that I no longer have the battery icon in my notification area.
And even though I have it set to Ask me when the power button is pressed, in Power Management, my laptop shut down now instead of showing me the options and the countdown timer.
This was my last update:

Operation #98: upgrade
Date: 2017-04-30 02:02

  • kernel-glue is upgraded from 3-190-1-x86_64 to 4-191-1-x86_64.
  • ghostscript is upgraded from 9.21-11-1-x86_64 to 9.21-12-1-x86_64 with delta.
  • firefox is upgraded from 53.0-92-1-x86_64 to 53.0-93-1-x86_64.
  • libplist is upgraded from 1.12-5-1-x86_64 to 2.0.0-6-1-x86_64.
  • nvidia-304-glx-driver-modaliases is upgraded from 304.135-135-1-x86_64 to 304.135-136-1-x86_64.
  • nvidia-glx-driver-modaliases is upgraded from 375.39-139-1-x86_64 to 375.39-140-1-x86_64.
  • simple-scan is upgraded from 3.24.0-4-1-x86_64 to 3.24.1-5-1-x86_64.
  • nvidia-340-glx-driver-modaliases is upgraded from 340.102-99-1-x86_64 to 340.102-100-1-x86_64.
  • linux-lts is upgraded from 4.9.24-22-1-x86_64 to 4.9.25-23-1-x86_64.
  • mesalib is upgraded from 17.0.4-54-1-x86_64 to 17.0.5-55-1-x86_64.
  • mesalib-demos is upgraded from 17.0.4-54-1-x86_64 to 17.0.5-55-1-x86_64.
  • libvte is upgraded from 0.48.2-18-1-x86_64 to 0.49.1-19-1-x86_64.

Hope that helps, and you can fix this new problem, thanks!

mate-user added a comment.EditedApr 30 2017, 1:54 AM

I also don't see a notification now when I unplug my laptop charger. Screenshot of my power management settings and missing battery icon:


Edit: Also just noticed, when I close my laptop lid and open it again, my laptop is not locked after waking from sleep!

Hi - please open a separate bug for the power stuff.

STiAT added a comment.Apr 30 2017, 9:11 AM

Worked for me - Windows boot option available after the update.

ikey closed this task as Resolved.Apr 30 2017, 9:32 AM

Certainly glad to be closing this one, hopefully for the last time. Thanks for testing, folks.

STiAT added a comment.May 2 2017, 8:11 AM

Can confirm it for my Win7 Enterprise machine at work as well - had the option after upgrade. So both, Win7 and Win10 worked (showing a vista for both for some reason - but that's not an issue as long as it recognizes it and boots correctly).

Running well except for the vista issue.

The incorrect Vista label can be fixed now by running "sudo update-grub" one last time. Now I see Windows 7 correctly. Thanks for the fix!