Page MenuHomeSolus

Huge notification pop-ups from Firefox; notification pop-up setting in Solus does not have any effect
Closed, InvalidPublic

Description

This is partly a Budgie issue, partly a Solus issue.. I was torn where to post this. Notifications pop up from Firefox regardless of the setting configured in Solus. They are also gigantic and cover up full-screen games.

Screenshot for explanation: https://i.imgur.com/qAKaPo7.png

These are the 3 main problems:

  • If you turn off pop-up notifications in Solus, these will still pop up
  • Notifications appear on top of full-screen games and take a long time to disappear on their own. Extremely annoying.
  • Notification height is unconstrained. The notifications can be so big that they extend well below the visible screen

How to reproduce:

  • Install Pushbullet extension in Firefox (57+, nightly in my case), as well as Pushbullet app on mobile (Android in my case)
  • Send yourself a long email
  • Wait for your phone to check for email, upon arrival it will activate the notification in your browser

I'd imagine anything would work that you can use to trigger a notification from Firefox.. Pushbullet is my test case.

This has been a really frustrating problem. I don't want to have to shut off notifications, or Pushbullet .. but I also can't deal with these pop-ups covering up a third of my screen all the time. Would be super appreciative if someone could take a look at this

Thanks

Event Timeline

Beer created this task.Dec 9 2017, 11:53 PM
JoshStrobl closed this task as Invalid.Dec 10 2017, 1:25 AM
JoshStrobl added a subscriber: JoshStrobl.

Budgie issues should go to https://github.com/budgie-desktop/budgie-desktop

Notifications pop up from Firefox regardless of the setting configured in Solus.

Because the setting you showed applies to GNOME Shell, not Budgie.

Beer added a comment.Dec 10 2017, 3:45 AM

Because the setting you showed applies to GNOME Shell, not Budgie.

When a user says to "turn off notification pop-ups", they would rightly expect that to mean all notification pop-ups, not just some of them. Isn't solus the only project that has any control over improving how that setting works? It seems like a legitimate issue but was closed as invalid.. should I submit a separate task just for that issue? I don't personally care if it's fixed as I prefer to have pop-ups turned on, I was just trying to shut Firefox up and noticed it. It seemed worth reporting

Lastly, where would you suggest I go to report the issue about notifications popping up on top of full-screen games? Is that a budgie thing? I'm not terribly familiar with the internal workings of that stuff.

Thanks

JoshStrobl added a comment.EditedDec 10 2017, 3:53 AM

should I submit a separate task just for that issue

No you should submit it in the right location. This isn't just a Solus issue, it's the fact we utilize GNOME Control Center for GNOME *and* Budgie, where Budgie doesn't utilize the GNOME Shell specific settings exposed in GNOME Control Center. As such, it's a Budgie issue, and thus should be reported to the right place.

Lastly, where would you suggest I go to report the issue about notifications popping up on top of full-screen games? Is that a budgie thing?

Correct.

Beer added a comment.Dec 10 2017, 4:02 AM

OK, will do. Some of these things are hard to pinpoint what project is responsible for those of us who don't write the code.. thanks for pointing me in the right direction

No problem =)