Page MenuHomeSolus

Installation fails with a NVIDIA GTX 970
Closed, ResolvedPublic

Description

It's not possible to install Solus with the latest ISO 1.2.05 in combination with a NVIDIA GTX 970. After booting solus from a live usb the display does not give any output. When using instead the onboard graphics from my i7 6700K it works fine. Because i get no display output there is not much more debugging information i can give.

Anything else i should provide to debug this issue?

Edit: I replaced quiet splash with nomodeset in goofiboot and was able to boot solus

Event Timeline

theSoenke created this task.Sep 8 2016, 8:59 AM
theSoenke updated the task description. (Show Details)Sep 8 2016, 9:20 AM
nexus added a subscriber: nexus.EditedSep 9 2016, 2:31 PM

I had the same problem on my setup.

nomodeset

solved the problem, too. I also have a GTX970.

The problem occurs on booting the solus iso and after the installation.

I've been struggling with Ubuntu on the same issue for the last 2 years (with a GTX 970 too). Never found any solution except by using 'nomodeset'. It's probably kernel related and not specific to solus.

nexus added a comment.Sep 9 2016, 2:33 PM

I've been struggling with Ubuntu on the same issue for the last 2 years (with a GTX 970 too). Never found any solution except by using 'nomodeset'. It's probably kernel related and not specific to solus.

Well i also have this kind of problem with ubuntu but only after installing the nvidia drivers.

JoshStrobl triaged this task as High priority.Sep 10 2016, 2:19 PM
WonderingDane added a subscriber: WonderingDane.

I also have this exact same problem with GTX 970.

Hello,

I think there is another thread regarding this as well. I thought I subscribed to it, but, cannot find it now. Perhaps it was in the forums. Also a gtx970 user with same symptoms as above. In order to install 1.2.05 I removed my gtx and then installed the nvidia drivers and reinstalled card. Perhaps there is a better way, but, I did not find any answers as to how here, forum or irc. Does not mean the answer did not exist, just my search foo found nothing.

Re ubuntu installs, I have found the opposite of @Paradoxeuh. I am in fact back on xubuntu 16.04 core install.

utybo added a subscriber: utybo.Oct 19 2016, 10:12 PM

Right so the problem is in Nouveau 2D driver itself. It dropped Maxwell support:

https://www.phoronix.com/scan.php?page=news_item&px=XOrg-Nouveau-Drop-GLAMOR

Basically we need to find a way around this or kill Nouveau.

It would appear that Maxwell acceleration returned: https://cgit.freedesktop.org/nouveau/xf86-video-nouveau/commit/?id=a24ded627e42d453546c553d609edc073f59cd57 (GX10 via EXA)

Next ISO will have to feature a patched Nouveau for this returned support

ikey changed the task status from Open to In Progress.Jan 12 2017, 5:04 PM
ikey raised the priority of this task from High to Unbreak Now!.

Calling for testers of an ISO: Please step up if interested!

utybo added a comment.Jan 12 2017, 5:09 PM

@ikey I can help, as I have a GTX 970 that encounters several problems with Linux related to this issue :)

utybo awarded a token.Jan 12 2017, 5:54 PM

In case more tester are needed i'm up for it

Stepping up!

I miss Solus :P

where do we find testing etc?

Also here to help out with testing a new iso snapshot with GTX 970 hardware. My current workstation has 2 of them in SLI so that would be a different scenario to test.

Side note: I'm thinking Solus would be a great platform to try out VFIO-VGA passthrough. So far, owning the 970's has been a complete pain trying to boot any distro under Nouveau.

Awwkaw added a subscriber: Awwkaw.Feb 10 2017, 9:00 AM

I would also like to test a new iso, if yet ore i needed

Thisuu added a subscriber: Thisuu.Feb 11 2017, 2:41 AM
Thisuu removed a subscriber: Thisuu.

will this problem persist in the new snapshot? (it hasn't gotten the ''snapshot febuary 2017'' flag)

aeosynth removed a subscriber: aeosynth.Feb 20 2017, 5:34 PM

OK sorry this has taken so long.

For those willing to test, please check with this ISO built last night: https://archive.solus-project.com/.donotdistribute/Solus-Budgie-Feb17-Validation.iso

Please DO NOT distribute the ISO or publish links to it. It would be harmful to reputation. It has not gone through rigorous testing nor is it in any way
a release of Solus. This exists *purely* for validation, not use.

f1883e4d04dc8ca7eb156baebbff01347f9012fceb594e9b6431912380389e4b  Solus-Budgie-Feb17-Validation.iso

Just tested it and unfortunately it still has the same issue for me

nor i can boot from it on gtx970

OK what errors are we seeing? What's the behaviour?

Also if people can try booting with nouveau.config=NvForcePost=1 in their kernel parameters too please!
Ref: https://bugs.freedesktop.org/show_bug.cgi?id=89664

Awwkaw added a comment.EditedFeb 25 2017, 9:01 AM
In T514#47504, @ikey wrote:

OK what errors are we seeing? What's the behaviour?

Without noveau.config=NvForcePost=1 the underscore blinks a few times and then a line of |||||| appear (a bit mobre spaced out) some white and some green, and then the screen goes black.

With noveau.config=NvForcePost=1 the underscore blinks a few times, and then the screen goes black

(i think i did put in the noveau.config=NvForce=1 the right way(just added it after quiet splash), since it changed the output, but not 100% sure)

aledbf added a subscriber: aledbf.Mar 1 2017, 5:14 AM

@ikey this iso solves the issues after the installation (dell Precision 5520 - Nvidia Quadro M1200)

kyrios123 added a subscriber: kyrios123.EditedMar 1 2017, 6:58 AM

@aledbf : this is because of the upgrade to the latest long lived nvidia drivers (T2603)

I installed Solus today using the latest ISO (Solus-2017.01.01.0-Budgie) on a Skylake, Nvidia 970 system and was unable to boot the live USB with the 970 in the computer. All distributions I've tested require integrated graphics be used until the proprietary graphics are installed but Solus was unique in requiring the card be removed from the system before booting. If booting with the 970 in the system the screen would go black and never progress. When CTRL + ALT + F1 was pressed a stream of *Nouveau* text was shown.

I was able to install Solus with the GPU removed. I then installed the Nvidia drivers, shutdown the computer, and reinserted the card. It worked.

JoshStrobl lowered the priority of this task from Unbreak Now! to High.Apr 11 2017, 2:43 PM
ikey added a comment.EditedMay 12 2017, 11:17 AM

We can try backporting these patches https://github.com/hpjansson/nouveau/commits/linux-4.10 and see if it helps

Need to know that the symptoms/config match as described here first though: https://bugs.freedesktop.org/show_bug.cgi?id=94990

utybo added a comment.May 12 2017, 5:04 PM

Yup, this matches my config and the symptoms (4GB VRAM, GTX 970 and GM204 all appear in lspci and nvidia's own X server configuration tool)

nexus added a comment.Jul 4 2017, 9:40 AM

Well it's quite troublesome with a GTX 970. Even using nomodeset and installing the drivers from the repo (nvidia-glx-driver) the hole system is laggy as hell. After manually removing the driver and installing the one from nvidia.com everything is fine. I don't know why.

Oatwalker added a comment.EditedAug 16 2017, 3:13 AM

I was able to boot the latest Solus 3 ISO on my Nvidia 970 system without issue. I think this problem is fixed.

edit:
I'm using UEFI mode.

marcus added a subscriber: marcus.EditedAug 18 2017, 2:16 AM

LIES All LIES!
Please discount my account of events. I had bigger problems with the monitor I was using. I had reinstalled Sollus 3 and then installed the drivers for Nvidia. I was crestfallen that nothing seemed to let me change the Xorg config to the monitor's resolution nor was I able to have it properly identified.

As a last chance measure, I used another monitor with the same resolution and it worked perfectly well. I'm very pleased to say that I'm glad I gave Solus another shot.

I really am enjoying this distribution! Thanks!

Ignore below the line

I just tried a Budgie Solus 3.0 ISO both EFI and legacy bios with an Intel motherboard, 7600k and Nvidia Gtx 970. It did not get past the point that graphic driver loads and fails with the Noveau. Failed at EDID detection as well. I had really hoped that it would work right away based on the previous success account.

I think the only way past this is to install a CLI and manually install the Nvidia Binaries manually when installing X and avoiding the installation of Noveau at all.

Marcus

JoshStrobl moved this task from Backlog to Other on the Hardware board.Oct 26 2017, 3:16 AM
devxpy added a subscriber: devxpy.EditedAug 17 2018, 8:44 PM

I just installed Solus on a gtx 1050 laptop using the "nomodeset" fix.

I am able to see the lock screen and login, but after that the mouse cursor just hangs on a black screen.

Any ideas on how I can resolve this?

I can't access other tty using Ctrl+alt+f1

P.S. it's a UEFI installation.

DataDrake closed this task as Resolved.Oct 21 2018, 2:58 PM
DataDrake claimed this task.
DataDrake added a subscriber: DataDrake.

I believe the 970 issue is either resolved or can be worked around with nomodeset reliably.